Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Tried to install CLAMAV via command line for Ubuntu Server 14.04.

Got the following error:

groot:/home/carlo# apt-get install clamav-freshclam
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
clamav-freshclam : Depends: clamav-base (>= 0.98.1+dfsg-4ubuntu1.1) but 0.98.1+dfsg-4ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.

I have tried to install it via the apt-get install -f command,but get the same error.

Outside of building from source is there a solution?

share|improve this question

4 Answers 4

Here is a work around if you don't mind adding a repository to your system. I was able to add the following repository and was able to download clamav-freshclam as well as clamtk. My guess is that the Ubuntu repositories for "trusty" is missing some stuff. I could verify that when I did a sudo apt-get build-dep clamav-freshclam which returned an error stating that the file was not available.

sudo add-apt-repository ppa:ubuntu-clamav/ppa

sudo apt-get update

sudo apt-get install clamav-freshclam

Hope this helps.

share|improve this answer

I tried the first suggest late last night after getting home, and it worked perfectly.

sudo apt-get clean
sudo apt-get autoclean
sudo apt-get install -f
sudo dpkg --configure -a
sudo apt-get install -f
sudo apt-get update
sudo apt-get install clam-freshclam

installed fine after that.

was weird because it wasn't indicating any other issues, just the missing dependencies for the one application.

share|improve this answer

I had the same issue, and I managed to find the problem....To fix it do:

sudo apt-get remove clamav
sudo apt-get remove clamav-base
sudo apt-get autoremove
sudo deluser clamav

Reinstall the antivirus....

sudo apt-get install clamav
sudo freshclam

Enjoy :)

share|improve this answer

Sorry for taking so long to update this. The unit that this was running on ended up failing - well - the SSD hosting the OS failed on it. No biggy. Reinstalled it recently with a new 250gb SSD. Will re-install Clam-AV and let everyone know the result once I get a free moment to do so.

Thanks again for all the advice!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.