Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I’m using ubuntu 14.04 on HP ProBook 4730s with AMD HD 6400m GPU.
I have some problems with proprietary\Opensource AMD driver in different games.
So i have to switch between drivers to play a particular game
I'm switching in System settings -> Software & Updates -> Additional Drivers But for some reason its not changing any more. It says "1 Proprietary driver in use" But it uses opensource driver

I tried to fully uninstall & install fglrx driver - no effect.
aticonfig --initial says that no supported GPU found

lspci:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series] (rev ff)

And AMD says that is supported
if I try to install latest driver from AMD site it fails with same error

your graphics adapter is not supported by this driver

How can I finally get it work?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.