Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a 1 TB HDD with seven partitions, one ~600GB for Windows and one ~300GB for Xubuntu and a bunch of assorted system partitions taking the rest of the space. I recently overwrote my Xubuntu partition with a fresh install since I messed it up somehow, and this is where my problem starts. Before, GRUB would show up at boot asking me to boot into either Xubuntu or Windows. After the reinstall this does not happen anymore.

I've tried running os-prober, but it just does nothing and outputs nothing. update-grub shows my Linux partitions alright but doesn't mention Windows at all.

Here's my layout (parted -l):

Model: ATA ST1000DM003-1CH1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  525MB   524MB   fat16        EFI system partition          boot
 2      528MB   570MB   41.9MB  fat32        Basic data partition          hidden
 3      570MB   705MB   134MB                Microsoft reserved partition  msftres
 4      705MB   2852MB  2147MB  ntfs         Basic data partition          hidden, diag
 5      2852MB  632GB   629GB   ntfs         Basic data partition          msftdata
 7      632GB   994GB   362GB   ext4                                       boot
 6      994GB   1000GB  6093MB  ntfs         Microsoft recovery partition  hidden, diag

os-prober output (just hangs there for a second and doesn't say anything):

marvin@ttyfsck:~$ sudo os-prober
marvin@ttyfsck:~$ 

update-grub output:

marvin@ttyfsck:~$ sudo update-grub
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-3.13.0-24-generic
Found initrd image: /boot/initrd.img-3.13.0-24-generic
Adding boot menu entry for EFI firmware configuration
done

fdisk -l output:

marvin@ttyfsck:~$ sudo fdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x314b8de1

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1  1953525167   976762583+  ee  GPT
Partition 1 does not start on physical sector boundary.

Boot-Info (long): http://paste.ubuntu.com/7416627/

Specs (again):
Xubuntu 14.04
Windows 8.1
1 TB HDD

EDIT: I can mount my Windows partition and view the contents no problem.

share|improve this question

2 Answers 2

You should use boot-repair. It will in most cases be able to help fix the problem.

Boot-Repair is a simple tool to repair frequent boot issues you may encounter in Ubuntu like when you can't boot Ubuntu after installing Windows or another Linux distribution, or when you can't boot Windows after installing Ubuntu, or when GRUB is not displayed anymore, some upgrade breaks GRUB, etc.

share|improve this answer
    
It tells me to disable Secure Boot. Is that a good idea? I'm not sure. –  CrateMuncher May 8 at 14:56
    
It should be a safe thing to do. Although you can educate yourself on the subject if you'd like, perhaps starting with this article: howtogeek.com/175641/… –  Xweque May 8 at 14:59
    
Okay, I did this, but it doesn't solve my problem. Still no Windows thing, although boot-repair saw Windows and listed it in the OS list. –  CrateMuncher May 8 at 15:09
    
Did you mean it listed it as you ran and not in GRUB or did it list it in GRUB and you couldn't boot to it? –  Xweque May 8 at 15:11
    
It listed Windows as an option where it lists OSs so you can pick a default one, but it's not in the GRUB menu. os-prober and update-grub doesn't do anything new either. –  CrateMuncher May 8 at 15:16

Try a Windows bootable repair / recovery CD or DVD to rewrite the Windows MBR and then do a update-grub operation. That should resolve it.

You can mount the Windows partition and view files so your Windows installation may be still intact. It's just that since there is no valid MBR entry for Windows, os-prober / grub is ignoring it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.