Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get the following error when trying to perform an update in Ubuntu 12.04 64bit:

installArchives() failed: Preconfiguring packages ...
Preconfiguring packages ...
Preconfiguring packages ...
Preconfiguring packages ...
dpkg: error: parsing file '/var/lib/dpkg/available' near line 40128 package 'foomatic-db-compressed-ppds':
 `Suggests' field, invalid package name `printer5driver-?2300w': character `?' not allowed (only letters, digits and characters `-+._')

Any ideas on how to solve this?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

It seems like your /var/lib/dpkg/available file is corrupted. So delete or move the current one and create a new file from backup.

sudo mv /var/lib/dpkg/available ~/Desktop
sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/available
share|improve this answer
1  
It worked! Packages are installing... –  user279365 May 8 at 11:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.