Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to set up OpenStack on MAAS, using trusty.

I have a network between these machines all bridged/switched together. I have set up MAAS at 192.168.7.200, I have a Juju client machine at 192.168.7.201, and my "normal" Laptop machine at 192.168.7.199. I have MAAS set to use 192.168.7.32-192.168.7.195. I have also set the router, 192.168.7.1/24 to also route for 192.168.64.1/19, which I intend to use later. I have MAAS set to manage DNS and DHCP.

I went ahead and bootstrapped Juju, and that worked. From my Juju client machine, I can ping the Juju bootstrap node:

juju status
environment: maas
machines:
  "0":
    agent-state: started
    agent-version: 1.18.2
    dns-name: c3enj.maas
    instance-id: /MAAS/api/1.0/nodes/node-d4feaf72-d658-11e3-8737-525400671a47/
    series: trusty
  "1":
    agent-state: started
    agent-version: 1.18.2
    dns-name: 3epj7.maas
    instance-id: /MAAS/api/1.0/nodes/node-37735c5c-d659-11e3-818d-525400671a47/
    series: trusty
services:
  juju-gui:
    charm: cs:trusty/juju-gui-2
    exposed: true
    units:
      juju-gui/0:
        agent-state: started
        agent-version: 1.18.2
        machine: "1"
        open-ports:
        - 80/tcp
        - 443/tcp
        public-address: 3epj7.maas
erik@openstackjuju:~$ ping c3enj.maas
PING 192-168-7-184.maas (192.168.7.184) 56(84) bytes of data.
64 bytes from 192-168-7-184.maas (192.168.7.184): icmp_seq=1 ttl=64 time=0.661 ms
64 bytes from 192-168-7-184.maas (192.168.7.184): icmp_seq=2 ttl=64 time=0.730 ms
^C
--- 192-168-7-184.maas ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 0.661/0.695/0.730/0.043 ms
erik@openstackjuju:~$ ping 3epj7.maas
ping: unknown host 3epj7.maas
erik@openstackjuju:~$ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 192.168.7.200
nameserver 192.168.7.200
search maas

I don't get what is going on here. How should DNS be set up?

I will say that I started out with setting nothing in the box "Default domain for new nodes" in MAAS, but then had some DNS lookup issues contacting the bootstrap node, so I decided to start over. I removed all machines from MAAS, set the setting to "vcluster.erikbandersen.com", and then erased/reset the harddrives on the nodes, and re-ran them through the PXE booting and commissioning process. I set the vcluster.erikbandersen.com to have an NS record that points to the MAAS server (though it is a private IP address, 192.168.7.200, so a recursive name server couldn't resolve the query). As shown before, my Juju client machine is set to look directly to the MAAS server for DNS queries, so it should hopefully be able to resolve the queries without running into trouble by going directly to the source, instead of asking a recursive nameserver that can't reach the private IP range to resolve the address for it. As you can also see, I can directly query the MAAS DNS server with dig, and it will not return any record for the machine.

erik@openstackjuju:~$ dig a 3epj7.maas

; <<>> DiG 9.9.5-3-Ubuntu <<>> a 3epj7.maas
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 54842
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;3epj7.maas.                    IN      A

;; AUTHORITY SECTION:
maas.                   300     IN      SOA     maas. nobody.example.com. 127 600 1800 604800 300

;; Query time: 0 msec
;; SERVER: 192.168.7.200#53(192.168.7.200)
;; WHEN: Wed May 07 21:08:58 PDT 2014
;; MSG SIZE  rcvd: 93

erik@openstackjuju:~$ dig a c3enj.maas

; <<>> DiG 9.9.5-3-Ubuntu <<>> a c3enj.maas
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 6111
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 1, ADDITIONAL: 2

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;c3enj.maas.                    IN      A

;; ANSWER SECTION:
c3enj.maas.             300     IN      CNAME   192-168-7-184.maas.
192-168-7-184.maas.     300     IN      A       192.168.7.184

;; AUTHORITY SECTION:
maas.                   300     IN      NS      maas.

;; ADDITIONAL SECTION:
maas.                   300     IN      A       192.168.7.200

;; Query time: 0 msec
;; SERVER: 192.168.7.200#53(192.168.7.200)
;; WHEN: Wed May 07 21:09:07 PDT 2014
;; MSG SIZE  rcvd: 113

What am I missing here? Why, after me setting the DNS setting to have "vcluster.erikbandersen.com" as the (post?)fix for the DNS, are names not in the format "3epj7.vcluster.erikbandersen.com" and instead becoming "3epj7.maas"? Further, why is the MAAS server itself answering DNS queries for some of the addresses but not all? Is there any way to debug this further?

Here is a debugging report generated with sosreport.

share|improve this question
    
I also tried rebooting the MAAS server, still the same thing. –  Azendale May 8 at 4:26
    
Which version of MAAS are you using? Try having a poke around in /etc/bind/maas/ and see if things "look right". It's hard to say exactly what you should see, but for starters you should see configuration for "vcluster.erikbandersen.com" instead of "maas". –  Adam Collard Jun 22 at 17:33
    
Did you try re-enlisting and commissioning the nodes after restarting the MAAS server? –  Adam Collard Jun 22 at 17:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.