Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a Newbie to Ubuntu. I just installed the xampp Linux version through xampp-linux-1.8.3-4-installer.run file.

Following are the commands that I used:

cd /home/sammy/Downloads 
sudo chmod +x xampp-linux-1.8.3-4-installer.run
sudo -s -H 
sudo ./xampp-linux-1.8.3-4-installer.run

sudo /opt/lampp/lampp start

It's done okay... then when I tried to access phpmyadmin it gives me following error:

Error MySQL said: Documentation #2002 
- No such file or directory The server is not responding (or the local server's socket is not
correctly configured). Connection for controluser as defined in your
configuration failed.

and when I see xampp manager it shows mysql service is stopped.

It's not even starting after so many retries from commands or GUI. My logs can be seen here.

Please help as soon as possible.

Thanks in advance

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Run this:

$ sudo apt-get install apache2 mysql-server mysql-client php5 phpmyadmin
$ sudo apt-get update
$ sudo apt-get upgrade

This should complete the partial install of the components you need. It should also upgrade the installed components.

share|improve this answer
    
it worked !! .. but there is still one problem I'm facing and that is phpmyadmin. I tried installing it by using following command : [ sudo apt-get install libapache2-mod-auth-mysql php5-mysql phpmyadmin ] but it not working . Can you Help me with this too .. thanks for previous help James :) –  Sammy May 9 at 2:04
    
Please check my updated answer. –  L. D. James May 9 at 3:07
    
same out put i get sammy@sammy:~$ sudo apt-get install apache2 mysql-server mysql-client php5 phpmyadmin [sudo] password for sammy: Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package phpmyadmin sammy@sammy:~$ ...... even i have tried updating apt-get –  Sammy May 9 at 6:45
    
Which distro/version are you running that you're missing the phpmyadmin repository? You can add the repository with: "sudo add-apt-repository ppa:tuxpoldo/phpmyadmin;sudo apt-get update" Then the command in the answer should work. –  L. D. James May 9 at 8:11
    
I'm using this version Ubuntu 14.04 LTS 32 bit. Since I've installed it my update never goes well , i always face error but following you guidance I end up with this now The following packages have unmet dependencies: phpmyadmin : Depends: php5-mcrypt but it is not installable E: Unable to correct problems, you have held broken packages. –  Sammy May 10 at 2:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.