Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

In Xfce, when I press Alt+Shift keyboard indicator switch between us and ru but the layout doesn't switch actually.

Xubuntu 14.04

I've tried: different keyboards (doesn't help).

This problem appeared after I remapped a certain key following this: How do I remap certain keys or devices?

Update. The problem affects KDE desktop environment too. In Unity everything is OK.

share|improve this question
    
I have the same problem here.. –  George Politis Nov 23 '14 at 11:38

1 Answer 1

When I had Xubuntu I had the same issue just for Hebrew. But playing with settings fixed it.

  1. Check that your system settings are correct (Settings -> Text Entry).
  2. Make sure also that shortcut is not taken in Keyboard Shortcuts and that no key associated with Next input method. Try to remove everything from Input Methods settings.
  3. Go to keyboard settings, and change layout configurations.
  4. Try to clean/reset mapping settings: How do I clear xmodmap settings?

If it still doesn't work try:

  1. Check that the plugin xfce4-xkb-plugin is installed (just run sudo apt-get install xfce4-xkb-plugin)
  2. try to map manually sudo setxkbmap -optiongrp:switch,grp:alt_shift_toggle us,ru
share|improve this answer
    
Installing xfce4-xkb-plugin makes the Alt-Shift "next input method" from "Keyboard Layouts / iBus Preferences" shortcut work. But If I use the iBus language icon widget on my toolbar, it somehow cancels Alt-Shift and it will no longer work until the next restart. It's good enough a workaround for me, though, because I prefer the keyboard shortcut. –  Eyal May 7 at 12:58
    
Glad to hear that. Cheers! –  guyromb May 10 at 15:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.