Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Xubuntu 14.04. After wake up from sleep, it asks to enter password. I entered the passw. and screen goes black. On Ubuntu 14.04 waking up was just ok. Lenovo E330 laptop with intel HD graphics.
add: If lid was closed, not clicked sleep

share|improve this question
2  
Perhaps this bug bugs.launchpad.net/ubuntu/+source/xfce4-power-manager/+bug/… ? – TuKsn May 7 '14 at 22:39
    
I just uninstalled lightlocker and installed xcreensaver. – Reza Jan 4 '15 at 9:35

I was able to work around the problem by going into settings, opening "Light Locker Settings" and setting "Enable light-locker" to off.

Learn more about light locker at http://xubuntu.org/news/screen-locking-in-xubuntu-14-04/

share|improve this answer

Strangely, one day when I fresh installed Xubuntu, that problem stopped. Still, if this happen, try using the following tip:

  1. Get into the command line using Ctrl+Alt+F1.

  2. Put your credentials user/password.

  3. Write the following:

    sudo service lightdm restart
    

So it will take you back to the login screen.

Hope that helps! (It's not a fix for this problem, though. I had to get used to click the Suspend button instead of closing the lid.)

share|improve this answer
1  
Doesn't Xubuntu use xdm as its default display manager instead of lightdm? – David Foerster Mar 26 '15 at 3:04
    
I can't give a full certain answer about it, but as a solution for that problem, it worked that way. I made that supposition because of how my given solution has worked for me, but I will edit it. – WolfangAukang Mar 26 '15 at 14:29
    
Problem with this, you need root access. I have to bug my boss to run this. All the same, good answer, should be the accepted answer. Note that on different models (hardware related? not sure) there is a range of Ctrl-Alt-FKeys that will open a text-based login, some I have seen, this only works on F4-F7. Off the top of my head (booted into Windows now, heresy, I know) I think it's Ctrl-Alt-F3 that gets you back to the graphical login? – JimLohse Feb 17 at 12:32
    
@JimLohse In Xubuntu, it is Ctrl+Alt+F7, if I'm not wrong. Now I'm Fedora, which is a different command, as you said – WolfangAukang Jul 25 at 3:17

This is all great and fine. But for a noob or anyone who is not accustomed to CLI it doesn't make the problem any less bothersome. Here is the solution that worked for me.

  • Completely remove Light Locker using Synaptic Package Manager
  • Install Gnome Screensaver from the Ubuntu Software Center
  • Restart the computer
share|improve this answer

My Lenovo E531 does the same. I insert the password and the screen goes black. Then I press the power button, I enter the password (again!) and everything it's fine. I know it's not the answer you needed, it's just a workaround than works for me. I hope it will help you too.

share|improve this answer

Had the same problem too. My solution was on Light Locker Settings too but I didn't disable light locker. I just enabled "Lock on suspend" and the problem solved.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.