Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

UbuntuOne is not working -- connection issues -- and I've been having trouble with using Funambol and SyncEvolution as a substitute, so I'd like to try to get Ubuntu One working for me.

I tried reinstalling it with Synaptic, I walked through the troubleshooting steps on UbuntuOne. When I open UbuntuOne from the "me" menu, it does appear to connect to my account -- it reports my usage and shows my current plan and devices, but it also says "disconnected"

I tried the fix at: Unable to connect to Ubuntu One

u1sdtool -s just sits there -- nothing happens and I don't get a new command prompt.

u1sdtool -q does report ubuntuone-syncdaemon stopped.

I removed my computer from the list, removed .cache/ubuntuone .config/ubuntuone and ~/Ubuntu One and tried to connect again. Now I'm getting a status response at least:

[0 amanda@luna ~]$ u1sdtool -s
State: READY
    connection: Not User Not Network
    description: ready to connect
    is_connected: False
    is_error: False
    is_online: False
    queues: IDLE

So I tried again -- did u1sdtool -q and this time there was also a .local/share/ubuntuone directory to remove, along with Ubuntu One and the ubuntuone directories in .cache and .config. I also did ps aux | grep ubuntu and killed two running processes:

amanda    3062  0.1  0.7  45372 23460 ?        SL   07:54   0:19 /usr/bin/python /usr/lib/ubuntuone-client/ubuntuone-login
amanda    7373 13.6  6.1 402320 189516 ?       Sl   10:27   1:48 /usr/lib/firefox-3.6.17/firefox-bin http://one.ubuntu.com/account

Then I u1sdtool --start followed by u1sdtool -c and Firefox did open the "connect this computer" dialog, which seems to have worked. So I seem to be connected. But man, oh man was that a pill.

Any idea how I should have gone about this to begin with?

share|improve this question

closed as too localized by fossfreedom Feb 23 '12 at 21:42

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Of course, I'm on 10.04 so this was all pretty much for naught since all I really want to sync is my contacts. Argh. wiki.ubuntu.com/UbuntuOne/FAQ/… –  Amanda May 31 '11 at 15:32
    
Hello, this question has no information and activity for a very long time. I am closing it for now. If by any reason you think this question is still viable or useful in anyway or that there is still a good chance it will be answered please flag it to a moderator or add a comment with the reason(s) why you want it open. Regards –  fossfreedom Feb 23 '12 at 21:42

Browse other questions tagged or ask your own question.