Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I successfully installed Ubuntu 14.04 on my macbook pro 9,1. Everything is now working correctly. Except I am unable to plug in a second screen.

If I plug in another screen :

  1. At system Boot: I get no display(black screen) after the initial console messages related to system start. Though in the black screen if I press ctrl+alt+f2 -> type my username -> type my password -> type sudo reboot -> type password. Then I can still reboot successfully.

  2. At runtime: I can see the second screen being detected by nvidia-setting page. But still the second screen has no display

I have tried the following:

  1. Change the drivers to Nouveau drivers
  2. Use the Nvidia 331.38 drivers
  3. Install BumbleBee: This gave me a black screen on my main monitor and I had to reinstall the Nvidia drivers after removing bumblebee. I was using this link for installing bumbleBee.But after rebooting my display goes away.

the output for lspci | grep VGA is:

01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 650M Mac Edition] (rev a1)

Please advice how I can have the second screen on my Macbook pro. My current driver version : 331.67

Updates: 1. When I connected DisplayPort-to-HDMI converter to my HDMI TV screen the second display started working as it is. I then tested my old monitor(which only has D-sub connector) using the chain:

DisplayPort-to-HDMI adapter-> HDMI-DSub adapter->DSub input of my monitor.

After changing to the correct resolution, my monitor is now acting as a secondary display. So I guess the problem is either : 1. With Display-port to D-Sub adapter I have(its china made) 2. OR there is a problem with all the Display-port to D-Sub adapters. I will test my friends adapter and post here later.

share|improve this question
    
Are you sure you got the model number right? It seems like 9,2 is the 2012 13 inch model which doesn't have nvidia graphics.. –  Anake May 6 at 9:13
    
Hi @Anake ,yeah I made a mistake. Corrected it now. Its 9,1 got it by typing 'sudo dmidecode -s system-product-name' –  Pranaysharma May 6 at 19:22
    
Have you found any thing useful? –  Krypton May 20 at 9:55
    
nope still stuck with one display :( –  Pranaysharma May 20 at 11:37
    
Have you tried turning off the Nvidia card (blacklist nouveau or whatever) and just using the Intel graphics? Intel graphics work great with dual or triple display on a Macbook. –  bain May 22 at 12:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.