Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have looked at this question but I get this error while compiling and am unable to load the module afterwards:

make -C /lib/modules/3.13.0-24-generic/build M=/home/owner/Desktop/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013_patched modules
make[1]: Entering directory `/usr/src/linux-headers-3.13.0-24-generic'
  CC [M]  /home/owner/Desktop/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013_patched/base.o
/home/owner/Desktop/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013_patched/base.c: In function ‘rtl_action_proc’:
/home/owner/Desktop/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013_patched/base.c:885:32: error: ‘struct ieee80211_conf’ has no member named ‘channel’
       rx_status.freq = hw->>center_freq;
/home/owner/Desktop/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013_patched/base.c:886:32: error: ‘struct ieee80211_conf’ has no member named ‘channel’ = hw->>band;
/home/owner/Desktop/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013_patched/base.c: In function ‘rtl_send_smps_action’:
/home/owner/Desktop/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013_patched/base.c:1451:24: error: ‘struct ieee80211_conf’ has no member named ‘channel’
   info->band = hw->>band;
make[2]: *** [/home/owner/Desktop/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013_patched/base.o] Error 1
make[1]: *** [_module_/home/owner/Desktop/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013_patched] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.13.0-24-generic'
make: *** [all] Error 2

This occurs with both the driver listed in the first link and the patched driver that I found.
I have also already tried disabling both the bluetooth and the adaptor.
Also I tried iwconfig wlan0 txpower 30.

share|improve this question
What is it about the built-in driver that isn't working as expected? Installing an older driver is seldom useful. – chili555 May 6 '14 at 13:06
@chili555 the signal constantly fluctuates no matter how far or close I am to the router. This is also true of the speed I get about 1/3 of the speed I get in windows then 1/2 a second later for about 30 seconds or more I get no data transfer and the cycle repeats. I just need a driver that WORKS... :( – user175999 May 8 '14 at 5:29

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.