Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

General discussion of usability issue

I'm having a few usability issues with the Unity Launcher. I'm using 11.04 with the Auto-hide feature activated.

When I go to close a window (or press the back button in a web browser) that is tiled on the left of the screen, I often activate the launcher which then covers the close button and the back button on the browser. Of course I could approach the back or close buttons slowly from the bottom and thereby avoid hitting the top left of the screen and activating the launcher. However, I have evolved the habit, presumably because it is more efficient, of doing the gross mouse move up to the very top left of the screen, and then the nuanced smaller move down to the close or back button. I think this is a standard principle of mouse movement in human-computer interaction.

Below is a screenshot of what I see, when my mouse goes slightly too far up and activates the launcher and hides the back and close buttons, which I was intending to press:

unity problem

Question

Thus, is there a way of making the Unity Launcher only show in response to a button click?

Update:

  • There is some other recognition of this issue here: http://ubuntuforums.org/showthread.php?t=1767743
  • I note that when I start "Launcher and Menus" there are only two choices. "pushes the left edge of the screen and touches the top left corner of the screen". Thus, this option may persist over and above reveal mode.
share|improve this question
add comment

2 Answers 2

Yes .

You should go to compizconfig settings manager (install ccsm if you don't have it), then go to unity's submenu and find the "reveal mode" (first thing on the first tab, can't miss it)

Then remove all corners and it will only reveal using a shortcut or button click

share|improve this answer
    
Thanks. That does make a lot of sense. However, I have now tried this. I logged out and back on, and the launcher still shows when I move the mouse to the top-left. Any ideas why the the setting might not have applied? Is there possibly some other setting that is preventing the update or some file I can manually edit? –  Jeromy Anglim May 31 '11 at 7:07
    
can you try experimenting with the "hide launcher" options as well? (IF you want to change them, of course) Edit : it might want some corner to exist and defaults to upper left one if none if there, try including a corner you never go to to see if it fixes anything. it seems improbable but there's no harm in trying –  Chriskin May 31 '11 at 8:17
    
I had an experiment. I tried setting the side to nothing or just the top right. I restarted Ubuntu. In all cases top-left still activated launcher. –  Jeromy Anglim May 31 '11 at 8:59
    
Then it must be as robin said - you should better file a bug report - i can see why many might find it annoying (even though on my notebook's rather large screen i never had such a problem) –  Chriskin May 31 '11 at 11:18
    
@Chriskin, I guess it is related to how I like to arrange my Windows. I like to tile windows to the left and right using shortcut keys and I like autohide because it allows me to use the entire screen. –  Jeromy Anglim May 31 '11 at 11:23
show 1 more comment

I think the "launcher" settings only allow a choice of the side + corner or just the corner.

share|improve this answer
    
My experience so far is consistent with that. I disabled the left side when I first installed Ubuntu. –  Jeromy Anglim May 31 '11 at 9:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.