Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After add the Manage Networks icon into the panel, I can see my Wi-Fi network on the list. So I click on the SSID and it prompt for a password. I enter the right or wrong password but nothing happens.

The access point is working fine, I have others devices connected to it working properly.

I've tried to compile the RTL8191SE driver but they have syntax errors.

More information:


dmesg | tail -n 30

$ uname -a
Linux lucio-net 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

$ lspci -nn | grep 0280
Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller [10ec:8172] (rev 10)

$ nmcli d
wlan0  802-11-wireless  disconnected

$ nm-tool
NetworkManager Tool

State: disconnected

- Device: wlan0
Type: 802.11 WiFi
Driver: rtl8192se
State: disconnected
Default: no


Wireless Properties
 WEP Encryption: yes
 WAP Encryption: yes
 WAP2 Encryption: yes

Wireless Access Points
 [SSID]: Infra, [MAC], Freq 2462 MHz, Rate 54 Mb/s, Strength 100 WPA WPA2
share|improve this question
Your dmesg output is pretty much just a USB drive being plugged in and then removed. Can you try connecting and immediately post the dmesg output again, hopefully to catch the wifi info? – Nattgew May 5 '14 at 22:27
I use a USB drive to get this output out of the machine. That's why I plug in & out several times. Anyway I updated the output. – Lucio May 6 '14 at 14:16
Which version of Lubuntu are you using? – levlaz May 8 '14 at 3:48
The last one, 14.04. – Lucio May 8 '14 at 3:56
It looks like your card is working, have you tried to reset the router, or change the password on the wifi to see if maybe there is some sort of weird issue there. Have you tried connecting to any other wireless network - or does this happen no matter which network you try to connect to? – levlaz May 8 '14 at 3:59
up vote 7 down vote accepted

I'm not sure you are using the network manager applet. I would recommend typing nm-applet and use that. In case you need a workaround with the command line, you can configure network manager using nmcli tool. The syntax for wireless connections is as follows:

nmcli dev wifi connect <(B)SSID> [password <password>] [wep-key-type key|phrase] [iface <iface>] [bssid <BSSID>] [name <name>] [--private] [--nowait] [--timeout <timeout>]

Just remove the things that you don't need and change the ones that you need. If you don't have a WEP network, just don't use the wep-key-type option. This should be enough for a simple WPA/2 connection:

nmcli dev wifi connect mynetwork password my-password
share|improve this answer
The nmcli command works perfect, but I would need to type it every time I boot. The nm-applet also works great, but I also need to type it every time I boot. Any idea in how to stick it there? – Lucio May 8 '14 at 4:27
@Lucio add it to the "applications start-up" that Lubuntu has. – Braiam May 8 '14 at 13:37
@Braiam, Your answer makes no sense. He's using Network Manager. The command he ran already saved the connection. The whole point of Network Manager is so you don't have to manually setup hacky startup routines. – Cerin Jul 25 '15 at 21:43
@Cerin I don't see where the problem is. He's using network manager, I'm using the network manager tool. What's wrong with that? – Braiam Jul 25 '15 at 23:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.