Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Although everything was working perfectly well, keyboard shortcuts like Alt+F4, Alt+TAB, etc. have suddenly stopped working in my Xubuntu 14/Xfce4 installation.

Nothing happens if I hit them, and oddly, if I try to close a terminal by Alt+F4, the letters ;3S get written in the console.

Of course, the shortcuts in "Settings>Window Manager>Keyboard" are all correctly configured, and I have checked in xev that the keys are still mapped correctly.

Where could this come from ?

EDIT: I localized the problem: it comes from xmodmap:

I have a .Xmodmap file in my home folder, containing only

keycode  21 = asciicircum dead_grave dead_circumflex dead_grave dead_tilde dead_ogonek dead_tilde
keycode  77 = NoSymbol NoSymbol NoSymbol

(so nothing related to Alt). If I remove it, shortcuts work again. Why ? How could I have both working at the same time ?

share|improve this question
    
What happens if you rebind it under xfce4-keyboard-settings or test another combination for Alt+F4 ? –  Tuknutx May 5 at 16:14
    
Did you have activated some special keys like Fn ? –  Tuknutx May 5 at 18:44
    
Completely resetting xfce by deleting ~/.conf/xfce4 did not help either. –  Klaus May 8 at 15:46
    
Is your alt key working? –  Alex May 9 at 11:33
    
I have the same problem which started recently on Ubuntu 14.04. Some keys work (Alt-F4) but not all (Alt-F2), and I think none of the keys I set in the XFCE keyboard shortcuts work –  David Fraser Jun 23 at 12:11
add comment

2 Answers 2

I got the same problem with Linux Mint months ago.

After trying many ways to fix it, i just install another environment (in that case, Cinnamon). The shortcuts fixed. Maybe it could help you.

share|improve this answer
add comment

This looks like it could be bug #1292290 - Window manager keybindings don't work after reboot. A workaround is mentioned there:

I found a workaround: clear before reassign!

To make a shortcut to work ok, select an action you want to reassign and click 'Clear' button until it will really empty. Sometime if there is some (hidden?) duplicates, you will still see some shortcut (the same or different), even you clicked 'Clear' button. In this case just click the button again. Since the action shortcut is really empty, just assign your custom one as usual, and it will work ok :)

and

Someone on #xubuntu or #ubuntustudio (can't remember) mentioned a workaround for this:

You simply have to delete the current key mapping twice before setting a new one. Then the new mapping will be stored in the config.

share|improve this answer
    
Probably not, since it is affected by xmodmap (see my edit). –  Klaus May 13 at 2:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.