Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

lirc_serial won't load because the serial port is already in use. dmesg reports

[   12.245857] lirc_serial: port 03f8 already in use
[   12.245862] lirc_serial: use 'setserial /dev/ttySX uart none'

back in the days I used to edit a file called /var/lib/setserial/autoserial.conf or /etc/serial.conf to set UART to none on the corresponding serial port. The first doesn't help and the later doesn't exist no more.

All the Howtos and threads on message boards concerning LIRC are from the stoneage.

Can somebody help me?

share|improve this question
Could you confirm if one of the answers worked, and mark it as answered please? – Martin Dec 29 '12 at 14:29

You can create /etc/serial.conf and put lines like

/dev/ttyS0 uart none

into it. /etc/init.d/etc-setserial reads this file. The setserial binary is part of the setserial package, which is a dependency of the lirc package, so it should be automatically installed.

share|improve this answer

Does it work when you load it manually?

sudo modprobe lirc_serial

Check your /etc/lirc/hardware.conf for those lines:


I've had have the same problem and this solved it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.