Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Historically, there is an "Enable Wireless" option that I can have ticked or unticked that is just beneath the "Enable Networking" option when I right click on the network bar.

Suddenly this disappeared one day, and I can't connect to wireless, nor does the option even exist to enable wireless.

The output for rfkill list all is below:

rfkill list all
1: tpacpi_bluetooth_sw: Bluetooth
Soft blocked: yes
Hard blocked: no

And that is all. There is no wireless that is being displayed.

The output for sudo lshw -C network is:

    *-network               
       description: Ethernet interface
       product: Ethernet Connection I218-LM
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eth0
       version: 04
       serial: 28:d2:44:4d:b6:89
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.0.0-k duplex=full firmware=0.6-3 ip=10.0.28.48 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:57 memory:f0600000-f061ffff memory:f063e000-f063efff ioport:3080(size=32)
  *-network UNCLAIMED
       description: Network controller
       product: Wireless 7260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 83
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:f0400000-f0401fff

Does anyone know how I can enable wireless? I have also tried:

sudo /etc/init.d/networking restart

and have checked to make sure drivers are up to date as well.

share|improve this question

1 Answer 1

There is the same discussion : I recommend to you to follow it, to resolv your problem !

"Enable Wireless" option is disabled in network settings

share|improve this answer
    
Yea i already went through all of those but none of it worked. It appears to be a different case as their wireless still appears when they do rfkill list all, whereas mine doesn't even show up there at all.... –  user3412393 May 5 at 1:30
    
You do not have a driver loaded for your device. either it is not loaded and needs loaded manually or you need to install the driver which normally for intel devices is not the case. –  Wild Man May 5 at 16:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.