Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today's update of Firefox to the 29 version makes browsing very slow.

For example Firefox incredibly lagging when I am zooming or moving on google maps.

Does anyone the same problem? How can I speed it up?

My OS: Ubuntu 12.04, x64

share|improve this question
    
Do you have any plugins/addons installed and if yes, which ones? –  bender May 4 at 23:54
    
Have the same problem (Ubuntu 12.04.4). Reset didn't help. Have all the things turned to "yes" though in unity_support_test -p... –  scofandr May 12 at 8:39

1 Answer 1

up vote 2 down vote accepted

You could try to reset Firefox to factory defaults, this is actually something Firefox proposes to do if it detects that the start-up takes too long. Beware, however, this procedure will delete all your installed add-ons and your search engine settings.

To do a factory reset, follow the instruction on this page.

Another thing you could check is whether hardware graphics acceleration is set up correctly. The answer to this question describes how to do that.

share|improve this answer
    
Well, that works for me! Thanks! –  madox2 May 5 at 13:18
    
I propose to first test this by first disabling all addons before reseting it via the 'help'->'Restart with addons disabled' to check if there will be any difference. –  Parto May 12 at 8:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.