Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded my Windows from 8 to 8.1 just now, then when I tried to log in to Ubuntu, I didn't get Grub, instead the following message appeared -

error
unknown file system
grub rescue>

Now, I logged into Ubuntu using Live USB and tried running boot-repair, but it gave me the following error -

An error occurred during the repair.

A new file (~/Boot-Info_2014-05-04__21h37.txt) will open in your text viewer.

In case you still experience boot problem, indicate its content to: boot.repair@gmail.com

You can now reboot your computer.

You may want to retry after deactivating the [Backup and rename Windows EFI files] option.

The boot of your PC is in Legacy mode. You may want to retry after changing it to EFI mode.

Content of .txt file is here - http://pastebin.com/L5ZNCTRe

share|improve this question

marked as duplicate by darent, karel, Radu Rădeanu, WarriorIng64, Avinash Raj May 6 at 9:12

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Thanks but it's not helping. I'm getting - ubuntu@ubuntu:~$ sudo grub-install /dev/sda1 Could not find device for /boot: Not found or not a block device. –  theharshest May 4 at 22:12
    
@theharshest Did you change the BIOS boot settings from EFI (or Secure Boot) to Legacy? –  Elder Geek May 4 at 22:13
    
@ElderGeek How to do that? Just need to disable Secure Boot? When I do that I get three options - UEFI only, CSM only and Both UEFI and CSM. –  theharshest May 4 at 22:15
    
@theharshest I'm just seeking information on how we got here. –  Elder Geek May 4 at 22:19

Browse other questions tagged or ask your own question.