Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been running Lubuntu 13.10 on a netbook with a French keyboard, with the default language set to English. When I upgraded to 12.04, the default keyboard layout changed to US.

At the login screen, the keyboard layout must still be French as I have to type in the password as if the keyboard were French. When I log into the guest session, the panel indicator shows the US layout but quickly switches to French before I can type anything. However, when I log into my own session, the keyboard remains US.

I have used lxkeymap to set the keyboard layout to French, but the change isn't permanent. Now, when I start lxkeymap the layout immediately switches to French. I have tried the solutions suggested here but none of them make the change permanent. How can I permanently set the default layout to French?

share|improve this question
    
Since you used the word upgrade, would it be correct to assume that your current Lubuntu version is 14.04? –  Rex May 4 at 23:55

1 Answer 1

up vote 1 down vote accepted

You can make adjustments to your keyboard layout by right clicking the flag or code in the LXPanel. Choose Keyboard layout handler settings. If you prefer the command line, see

http://lxlinux.com/#19

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.