Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded my Samsung NC10 netbook with Broadcom BCM 3411 WLAN to 14.04.

I'm not seeing any wireless connection choice under Network Manager, but it connects just fine on ethernet.

Ubuntu newbie, so may be missing something obvious.

Ran rfkill list all:

sudo rfkill list all 
0: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
1: samsung-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Also ran lshw -class network:

sudo lshw -class network
  *-network               
       description: Network controller
       product: BCM4311 802.11a/b/g
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=wl latency=0
       resources: irq:16 memory:f0100000-f0103fff
  *-network
       description: Ethernet interface
       product: 88E8040 PCI-E Fast Ethernet Controller
       vendor: Marvell Technology Group Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 13
       serial: 00:13:77:d1:ff:97
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.30 duplex=full ip=10.0.0.47 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:42 memory:f0200000-f0203fff ioport:2000(size=256)

All assistance much appreciated! Thanks!

share|improve this question
    
Not sure if this will work with 14.04, but you may want to check out Samsung tools, as referred to here... it's possible that your device doesn't actually have WiFi toggled on... linuxg.net/… –  Kendor May 4 at 20:46
1  
Please do what is in the accepted answer in the link below so we may see the information needed to help diagnose the issue. <askubuntu.com/questions/425155/…; –  Wild Man May 4 at 20:58
    
Thanks @kendor, tried to install Samsung Tools, but got an error, "unable to locate package samsung-tools" –  user277954 May 5 at 0:21
    
Thanks @wildman, results of script run at pastebin.ubuntu.com/7395995 –  user277954 May 5 at 0:36

2 Answers 2

up vote 1 down vote accepted

Please do with an iternet connection:

sudo apt-get purge --remove bcmwl-kernel-source
sudo apt-get update
sudo apt-get install linux-firmware-nonfree
sudo modprobe b43

wireless should now be working.

share|improve this answer
    
that did the trick - thanks you so much, I really appreciate the help! –  user277954 May 5 at 4:05
    
Please accept the answer so everyone can benefit from the solution. –  Wild Man May 5 at 4:18
    
done! Thanks again! –  user277954 May 5 at 4:20

Try running Additional Drivers and see if an option comes up for your Broadcom wireless driver. Failing that try holding Fn and tapping F9 as this should toggle the wireless on and off (watch for an LED status change) See page 87 of the manual you'll note that the wifi is an option that may or may not be installed. If not you may need to acquire a USB wifi adaptor

share|improve this answer
    
...and how do you do it in 14.04? –  mikewhatever May 4 at 20:43
    
@mikewhatever same way –  Elder Geek May 4 at 20:59
    
Thanks, I did try that, but no available drivers came up. However I did find this post, help.ubuntu.com/community/WifiDocs/Driver/…12.10.28Quantal_Quetzal.29-1, and updated B43 drivers as suggested, but still seeing no difference. I still think there may be something simpla that I am missing here... –  user277954 May 5 at 0:10
    
@user277954 as Kendor said "it's possible that your device doesn't actually have WiFi toggled on.." Lasptops often have a swirch or Fn key to toggle the state of wifi and a led to indicate status. researching your model –  Elder Geek May 5 at 0:39
    
Your Bluetooth is Broadcom, Your wireless is Atheros provided your true model number is NP-NC10 –  Elder Geek May 5 at 0:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.