Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In the following picture,

enter image description here

If you switch to the web browser, then switch to gedit again by clicking on the icon on the launch bar on the left, the workspace will switch automatically to the workspace below. This is very frustrating when, for example, you are processing some data from one application, and typing it in another application.

Without removing workspaces altogether, is there a way to disable this automatic workspace switching but still allow manual switching?

share|improve this question

2 Answers 2

up vote 2 down vote accepted
+50
  • Install CompizConfig Settings Manager

    sudo apt-get install compizconfig-settings-manager
    

I'm not sure if there is otherway, but this works for me. In Ubuntu 14.04.

  • Launch ccsm → Desktop Wall → Viewport Switching → Uncheck Auto Switch Vp and Window (Check&Uncheck if was Unchecked already)

Well, Auto Switch Vp and Window is not available in Ubuntu 12.04. Then disable Desktop Wall plugin. Tested on a VirtualBox.

  • Launch ccsm → Uncheck Desktop Wall

enter image description here

share|improve this answer
1  
Unfortunately this does not work on 12.04 - the "Auto Switch Vp And Window" option does not exist. Perhaps I'll use this after upgrading to 14.04 then. Anyway, thanks. –  ace May 7 at 10:05
    
@ace, I agree its not there, in 12.04. may be on other plugin? I will check. –  Sneetsher May 7 at 10:43
    
@ace, updated for 12.04 –  Sneetsher May 7 at 11:09
1  
Well, it works, but now I don't have the keyboard shortcuts to switch between workspaces. I would love to see another option which allows me to keep them, but if I don't I will accept your answer and award you the bounty after the expiration date. –  ace May 7 at 14:43
1  
@ace you can use Expo too (Default Super+S) to switch between workspaces. It is not as quick, but gets the job done. Still disable the wall, but you can drag/drop vs. ctrl+alt+arrow –  No Time May 12 at 16:36

Upgrade to 14.04 LTS.

Unfortunately, this is a bug in older versions of Unity, including the one in 12.04. I was just as annoyed by this as you are! It was only recently fixed—but only in the version of Unity included in 14.04.

Unless someone can figure out how to make the newest version of Unity work with 12.04 (I imagine that would break a bunch of stuff), the only solution I am aware of is to upgrade to 14.04.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.