Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I wanted to install XUbunutu looks on my Ubuntu machine and I have done it like so:

sudo apt-get install xubuntu-desktop

But now when I have restarted the machine, I first got xUbuntu log-out scree. WHen I got back to the login screen, I got Xfce (xubuntu) login screen, and even I login to the unity, I have xfce icons set up and the colors of the menu. Like this enter image description here

What I would like is to have a Ubuntu like login screen, and the ubuntu looks when I login to ubunty (unity) and not some mixed xfce-ubunty experience.

I have tried

sudo apt-get update 
sudo apt-get install --reinstall ubuntu-desktop
sudo apt-get install unity

and

dconf reset -f /org/compiz/

unity --reset-icons

But it didn't work.

Can someone help me how to return the original Ubuntu looks when I get to the login screen and when I login to unity UI ?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

What seems to have happened is that XFCE have changed some settings on your system, as such, your Ubuntu looks the way it does. You're going to have to reset some of these settings back to their defaults by running a few commands.

Reset Icons

gsettings set org.gnome.desktop.interface icon-theme 'ubuntu-mono-dark'

Reset Theme

gsettings set org.gnome.desktop.interface gtk-theme 'Ambiance'
gsettings set org.gnome.desktop.wm.preferences theme 'Ambiance'

Reset Login Screen

sudo dpkg-reconfigure lightdm

The above will fix the looks of the unity. Next is the login screen.

Reset Login Screen

There are two options for this:

First:

Run these commands:

sudo update-alternatives --config default.plymouth

Then choose your ubuntu option: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth

And then run: sudo update-initramfs -u

Second:

Run in terminal:

sudo dpkg-reconfigure lightdm

After running the second (or even the first option) you will probably NOT see the results just yet. As those scripts are not updating all necessary files, edit the lightdm.config file (thanks to help of this post http://askubuntu.com/a/421322/223469):

sudo gedit /etc/lightdm/lightdm.conf

And change values to (previous value was probably xubuntu):

user-session=ubuntu
greeter-session=unity-greeter

Save and reset.

After those changes the login screen should appear.

All what is left to do is to return loading screen, but so far I haven't managed to do that, but will update once I find the solution

share|improve this answer
    
Hm, okay, I will try with that, but there are other things that are a bit different - notifications (that I haven't mentioned in he questions) and also the login screen is from xfce and I would like to return to unity. Is there a way to do that, but resting unity or something like that? –  Aleks May 4 at 14:20
    
How are the notifications different? I have also included the login screen fix. –  Micheal Harker May 4 at 14:21
    
well they look just like the notifications on xubuntu - the color, position etc. For example: the notification for low disk space is displayed as a notification box right under the clock, but on Ubuntu this notification is shown as a separate window and no notification is shown. Also the login fix didn't work :/ the screen is the same as before –  Aleks May 4 at 14:27
    
Can you try sudo sh -c 'echo "/usr/sbin/lightdm" > /etc/X11/default-display-manager' to try and change the login screen? –  Micheal Harker May 4 at 14:31
    
I have tried. Nothing changed –  Aleks May 4 at 14:39

Did you try Unity Tweak Tool?

sudo apt-get install unity-tweak-tool

Then launch in terminal: unity-tweak-tool, go to Appearance→Icons→Ubuntu-mono-dark, Appearance→Theme→Ambiance etc (Try to chose different ones and back to default like Ambiance)

For login screen try:

sudo dpkg-reconfigure lightdm

If you have problem with boot screen try:

sudo update-alternatives --config default.plymouth

Chose number of: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth (default)

Then: sudo update-initramfs -u

share|improve this answer
    
I have to be careful with the suggestions. It seems that with this one I would be installing a new lightdm with in essence is not the standard unity login for 13.10 as I can recall. Also adding a new tweaks seems that drives me even further from just "reseting" the old unity style login and other settings (?) –  Aleks May 4 at 14:24
    
I have tried the suggestions even with sudo update-initramfs -u to update the login screen, but it didn't work. All stayed the same - still xubunty shown :/ –  Aleks May 4 at 14:50
    
sudo update-initramfs -u is for boot screen. LightDM looks like this, it is default 13.10 login screen. You can tweak your PC far as you like –  Paul B May 4 at 14:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.