Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 14.04 on my Thinkpad T60 and found out that Unity is too slow. So, I did

sudo apt-get install xubuntu-desktop

When I log into an Xubuntu session, the panel has a ton of junk from the Unity interface (a Power menu with a non-working logout button, an extra language indicator that does not work, an extra clock).

extra junk in the panel

How can I get rid of them, ideally without breaking my ability to log into Unity?

EDIT: I found other questions that ask about the same problems. They do not seem to have any useful answers:

Xubuntu strange behaviour panel-indicator and panel-notification applet

Xfce top panel indicator problem

share|improve this question
    
Can you remove it in the panel properties, items tab (description here linuceum.com/Distros/osDesktopConfigXfce.php) ? –  TuKsn May 4 at 8:46
    
This link worked well for me. It removes most of the slower features of 14.04. –  user265064 May 7 at 19:06

1 Answer 1

That is the new XUbuntu panel plugin for the new Unity indicator (libindicator & libappindicator).

  1. Right click on the panel → panel → Panel Preferences... → Items tab

    Then select Indicator Plugin

    enter image description here

  2. Either you remove it completely from panel using (-) button, or as I recommend customizing it.

    • Click (gear) button
    • Check "Hide indicators by default"
    • Check "Application Indicators" to be "Visible"

    Why? because some application uses only libappindicator method to show their status icon. You may not want to miss them.

    enter image description here

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.