Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

ifconfig -a produces:

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1812 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1812 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:209274 (209.2 KB)  TX bytes:209274 (209.2 KB)

wlan0     Link encap:Ethernet  HWaddr 28:cf:e9:1a:43:cd  
          inet addr:192.168.12.11  Bcast:192.168.12.255  Mask:255.255.255.0
          inet6 addr: fe80::2acf:e9ff:fe1a:43cd/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11512 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11320 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:9240182 (9.2 MB)  TX bytes:2316647 (2.3 MB)

lspci -nn | grep Ethernet produces:

03:00.0 Ethernet controller [0200]: Broadcom Corporation Device [14e4:16a3] (rev 10)

cat /etc/network/interfaces produces:

auto lo

iface lo inet loopback

Any ideas on how I can get eth0? Thanks!

share|improve this question

marked as duplicate by muru, Eliah Kagan, Eric Carvalho, Tim, Lucio Sep 3 at 3:14

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Adding the lines allow-hotplug eth0 and iface eth0 inet dhcp to the interfaces file should work, if you use DHCP and no network manager. –  Alex May 4 at 4:23
    
I added those 2 lines to the file and rebooted, but still dont see eth0. I think it has to do with the drivers, but I'm not sure. –  Indiana Jones May 4 at 4:34
    
After making the changes to the file (and saving) bring all interfaces down and eht0 up. To do that issue ifdown wlan0 (will disconnect from the internet, use ifup to bring it back) ifdown eth0 ifup eth0. Report back if it doesn't work. (Note all commands must be issued as root or with sudo, as well as making the changes to the interfaces file). –  Alex May 4 at 4:35
    
I saved those changes. When I do ifdown wlan0, I get the error - ifdown: interface wlan0 not configured. –  Indiana Jones May 4 at 4:37
1  
I disabled networking for the menubar on top. Then ran sudo ifup eth0. Got the error - Cannot find device "eth0" Error getting hardware address for "eth0": No such device Failed to bring up eth0. –  Indiana Jones May 4 at 4:41

1 Answer 1

Check whether your interface has the name eth0 by typing ifconfig -a.

Probably it is named something like p1p1 now. If it is and you want it to be eth0, add biosdevname=0 to the boot options in your /etc/default/grub.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.