Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a virtual server hosted by professionals with Ubuntu 10.04 installed. It is a standard server installation with LAMP package and no custom modifications.

After recent updates via aptitude boot time of the machine have increased dramatically to over 20 minutes. I noticed that this problem started occurring after updates of linux kernel.

The current version is: Linux Ubuntu-1004-lucid-64-minimal 2.6.32-32-server

Judging from the output of dmesg it looks like some sort of a problem with USB controller or drivers (dmesg output below). What I don't understand is why it started to happen? And what is the solution/workaround to this problem.

I've found that some people had similar problems and proposed solutions were either disabling USB legacy support in BIOS or upgrading firmware. As I have already mentioned, this machine is a virtual server, so i don't have access to BIOS and hardware.

[    0.197693] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    0.198259] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    0.198723] uhci_hcd: USB Universal Host Controller Interface driver
[    0.199237] uhci_hcd 0000:00:01.2: PCI INT D -> Link[LNKD] -> GSI 11 (level, high) -> IRQ 11
[    0.199979] uhci_hcd 0000:00:01.2: setting latency timer to 64
[    0.199988] uhci_hcd 0000:00:01.2: UHCI Host Controller
[    0.200470] uhci_hcd 0000:00:01.2: new USB bus registered, assigned bus number 1
[    0.201313] uhci_hcd 0000:00:01.2: irq 11, io base 0x0000c020
[    0.201917] usb usb1: configuration #1 chosen from 1 choice
[ 1253.897084] hub 1-0:1.0: USB hub found
[ 1253.897529] hub 1-0:1.0: 2 ports detected
[ 1253.897963] PNP: PS/2 Controller [PNP0303:KBD,PNP0f13:MOU] at 0x60,0x64 irq 1,12
[ 1253.899106] serio: i8042 KBD port at 0x60,0x64 irq 1
[ 1253.899529] serio: i8042 AUX port at 0x60,0x64 irq 12
[ 1253.914297] mice: PS/2 mouse device common for all mice
[ 1253.915268] rtc_cmos 00:01: rtc core: registered rtc_cmos as rtc0
[ 1253.916198] rtc0: alarms up to one day, 114 bytes nvram, hpet irqs
[ 1253.917255] device-mapper: uevent: version 1.0.3
[ 1253.920528] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input2

Update 1

The problem just went away, on 2 separate servers. After several reboots the 20 minute delay no longer occurs. No modifications to the server configuration have been made. I am suspecting that either:

  1. Kernel learned itself how to eliminate the delay or
  2. Hosting provider changed hardware configuration (improbable due to short time span)

I will keep monitoring boot times and will update the question if it occurs again.

Update 2

The problem still exists! It seems to occur only when reboots are days aways from each other. Consecutive reboots don't produce this delay.

Adding noapic flag to boot parameters does not help.

The delay always occurs between the following lines of dmesg, with varying duration:

[    0.189478] usb usb1: configuration #1 chosen from 1 choice
[  487.589964] hub 1-0:1.0: USB hub found

Can anyone help?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Adding nousb to boot options is a workaround for this problem. It disables the whole USB subsystem during boot, hence, no delay.

I answered (from what you have written) a similar question here.

share|improve this answer
    
@fossfreedom Should I set GRUB_CMDLINE_LINUX_DEFAULT="nomodeset noapic" in the /etc/default/grub and then do a sudo update-grub? By the way, I just rebooted again and there was no 20 minutes delay and that is without making any changes! –  dezlov May 30 '11 at 14:46
    
If you are convinced that one or both of the options is required, then go ahead make the change. However I'm confused that you said that the issue doesnt occur on a reboot when you have yet to make the change... Maybe add the options and monitor the situation over a period of time to see if this is the real answer. –  fossfreedom May 30 '11 at 14:51
    
The only thing that I did between reboots is installed bootchart, which seems to have modified the boot image somehow. I have another server with previous linux kernel 2.6.32-31-server and no bootchart, rebooting it right now and it already spent 10 minutes doing that. Will run few more tests and report back. –  dezlov May 30 '11 at 15:01
    
@dezlov - what virtualisation solution are you using? If you are using virtualbox - have you tried disabling the USB-Controller in the guest settings? –  fossfreedom Jun 15 '11 at 19:09
    
I do not host the virtual machine myself, it is hosted by a professional hosting provider. While I was searching for the solution, I came across suggestions to disable USB ports or legacy support (mostly via BIOS), but haven't found a single definitive way of doing this in software on Ubuntu. –  dezlov Jun 15 '11 at 20:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.