Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Ubuntu machine can connect to my WPA network, but there's not a trickle of internet to be found. It works fine with another (but farther) WEP network.

Windows system on the WPA network work fine (I'm using one to write this question). Wired connection to the router broadcasting the problematic network is also fine.

Do note that I did not try to connect to network using Windows on the same machine. It's an Atheros card - I will include more details if requested.

Oh and I the other systems on the network are visible as well.

EDIT I've removed the Ethernet details from the following output:

~$ sudo lshw -class Network

       description: Wireless interface
       product: AR5001 Wireless Network Adapter
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan2
       version: 01
       serial: 00:22:69:18:f1:d3
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath5k driverversion=2.6.38-8-generic firmware=N/A ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11bg
       resources: irq:18 memory:55200000-5520ffff
share|improve this question

closed as too localized by Marco Ceppi Jul 11 '11 at 13:40

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Please add the version of ubuntu you are using together with the exact model of Atheros card - sudo lshw -class Network. TIA – fossfreedom May 30 '11 at 14:18
@fossfreedom, done! – Oxwivi May 30 '11 at 14:29
maybe suffering from this bug? There is a suggested solution in the bug report. – fossfreedom May 30 '11 at 14:36
@fossfreedom, I can view networks and connect fine, just not getting internet connection (IP resolve problem?) and the solution hard codes the network details - I'd rather have Network Manager to manage where I connect. – Oxwivi May 30 '11 at 14:40

Good network connection without Internet access could mean that you are behind a proxy server. Check in the working computers if a proxy is set and you can add it in Ubuntu with in System -> Preferences -> "Network Proxy".

To validate if this is your problem, you should be able to ping a website in the terminal using for instance > ping but the browser will not be able to access to the website.

If the ping fails, then the proxy is probably not your problem. You could then check if you have a DNS server in /etc/resolv.conf and set one if not. I usually test with OpenDNS ( or when something is not working because it is available most of the time and from anywhere. Set these two addresses in /etc/resolv.conf like this:


and then try to ping a website again. If ping works but there is still no internet in the browser, then check proxy as described above and add it if necessary.

Hopefully the Internet connection will work after trying this...

share|improve this answer
Nope, it ain't no proxy issue, I mess with them (on other computers as well) so I should know. – Oxwivi May 30 '11 at 15:34
And as mentioned have you checked if DNS server was accessible by simply pinging a known working website? – jmbouffard May 30 '11 at 15:40
Yeah, I've pinged Google before as well. And just for the record, it isn't a DNS issue since I can access internet from the other network and both networks connect to the same ISP. – Oxwivi May 30 '11 at 15:47
It could still be a DNS issues because each computer must be well configured with the DNS. So if for some reason your computer does not have the right DNS information it will not be able to ping nor to access websites. Usually the DNS info is passed to your pc along with the DHCP request so if you have a static IP address you will need to set your DNS info in the /etc/resolv.conf file. – jmbouffard May 30 '11 at 15:52
Each? I'm connecting to both networks from the same machine. And did I mention I tried Google DNS as well? – Oxwivi May 30 '11 at 16:02

A very recent thread on Ubuntu Forums reported a suggested fix involving three changes to your Natty install:

  1. Installing the latest madwifi drivers
  2. Blacklisting the existing Ath5k kernel module
  3. Using WiCD instead of Network Manager

Follow the step-by-step guide here - post #4.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.