Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Running a clean install of ubuntustudio 14.04 the suspend and resume works when using the power button or selecting it from the user menu but is not available in the xfce4-power-manager-settings. Only "Lock Screen" or "Nothing" is available for lid close action.

http://docs.xfce.org/xfce/xfce4-power-manager/faq Suggests that it is likely permissions issue since suspend/resume clearly works.

My single user on a single user system has the following group memberships: username adm cdrom sudo audio dip plugdev lpadmin sambashare

Any suggestions? I'd rather not fry my new hdd because I forgot to suspend and just close the lid.

Updates:

  • Changing "/etc/systemd/logind.conf" settings have no effect.
  • This appears to be a bug in upower https://bugzilla.redhat.com/show_bug.cgi?id=1005234
  • I've confirmed this is not an issue with my hardware on the standard ubuntu desktop (using a live drive)
  • I've confirmed this is not an issue with xubuntu!?! (I had to enable suspend in the xfce4-power-manager-settings but it was an option)
  • Changing kernel to linux-general has no affect.
  • xfce4-power-manager --dump & sudo xfce4-power-mangager --dump
---------------------------------------------------
       Xfce power manager version 1.2.0
With policykit support
With network manager support
With DPMS support
---------------------------------------------------
Can suspend: False
Can hibernate: False
Can spin down hard disks: True
Authorized to suspend: True
Authorized to hibernate: True
Authorized to shutdown: True
Authorized to spin down hard disks: False
Has battery: True
Has brightness panel: True
Has power button: True
Has hibernate button: True
Has sleep button: True
Has LID: True
share|improve this question
    
Does a change in the "/etc/systemd/logind.conf" have any affect? Try to uncomment "#HandleLidSwitch=suspend" to "HandleLidSwitch=suspend" (without quotes). More info: freedesktop.org/software/systemd/man/logind.conf.html –  TuKsn May 4 at 10:35
    
Yes I have tried that setting in "/etc/systemd/logind.conf", it doesn't seem to have any affect on either the suspend behavior or the availability of suspend in the xfce4-power-manager-settings program. –  Nate Iverson May 5 at 1:47
    
Did you restart the systemd daemon after the changes sudo restart systemd-logind ? –  TuKsn May 5 at 16:27
    
I restarted the computer. That restarts the systemd daemon right? –  Nate Iverson May 5 at 16:36
1  
Sneetsher, I previously had tried pm-utils but wasn't sure if I had rebooted it. I double checked with the xubuntu iso and xubuntu has pm-utils installed by default. Trying again with a reboot solves the problem. Submit as an answer and I will give you the bounty. –  Nate Iverson May 9 at 12:59

1 Answer 1

up vote 2 down vote accepted
+100
  1. Install pm-utils

    sudo apt-get install pm-utils
    
  2. Reboot

Reference: [Solved] Issues with xfce4-power-manager-1.2.0

Discussion resume that: upower is relying on pm-utils to check for suspend/hibernate capability.

The broken link in the reference page should point to related bug report: Debian bug#639754 [upower] upower doesn't verify correctly the "suspend" and "hibernate" capabilities correctly

Not sure about this as upower package has Depends: pm-utils | systemd | systemd-services. I thought they should be alternatives. So may be there is other solution using systemd-services which is installed by default.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.