Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
My computer boots to a black screen, what options do I have to fix it?

I just installed a new update then restarted my laptop. The update was recommended, as I haven't logged in in a while. However now when I start my laptop, I am stuck in a cycle of login screen -> black screen -> and back to the login screen.

My credentials are correct, etc, and its looks like it will continue to log in however it reverts back to the login screen.

Anyone has any idea how to overcome this problem? How to get into my system without needed this log in? I have tried logging in with the failsafe GNOME and xtern etc, but it makes no difference.

I have seen something about 'SystemRescueCD' however I do not have access to a computer with CD burning capabilities for at present, so I unfortunately do not have that way out at the moment.

share|improve this question

migrated from May 30 '11 at 11:58

This question came from our site for professional and enthusiast programmers.

marked as duplicate by hexafraction, RolandiXor, Anwar Shah, RobotHumans, Jorge Castro Sep 22 '12 at 14:54

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

When you created your account, did you choose to have an encrypted home directory? – BZ1 May 30 '11 at 10:36
i created this account a year ago....I just simply logged in today as normal, ran the updates, restarted and now it does this – user291652 May 30 '11 at 10:46
But to answer your question - no I did not create an encrypted home directory – user291652 May 30 '11 at 13:15

Try this:

  1. Boot pc
  2. When presented with login screen press ctrl + alt + f1
  3. Login
  4. Backup your home folder /home/<username> by executing the command sudo mv /home/<username> /home/backup
  5. Then recreate your home folder by sudo mkdir /home/<username> and set file permissions by typing sudo chown <username>.<username> /home/<username>
  6. go back to graphical login screen (ctrl+alt+f7/f8 depending on your config), or reboot, and try and login.

This will determine if the issue is caused by your user profile. if you are able to login after this, then you can copy over the items and settings you want from the backup folder.

Remember that username is case sensitive. so if your username is dave, then don't type Dave or DaVe.. type dave where <username> is specified.

share|improve this answer
When I click 'clt+alt+f1' and log in, I am unable to run any commands, it says that sudo is not recognised nor is mv or 'ls' etc. ?? Thanks. – user291652 May 30 '11 at 11:07
It seems you have a very serious problem indeed ;) Your best bet is to use an ubuntu live memory stick (or cd), boot the machine up in the live environment. Make any backups of your home folder to another machine or usb disk. And then reinstall ubuntu. Alternatively you could always try to fix your system, but as i take it you are not a very experienced ubuntu user, id say a full re-install would be less frustrating :) – netbrain May 30 '11 at 11:12
I have tried this also, however when I test out my ubuntu live cd, I cannot alter files in anyway, I do not have permissions - I have also went through tutorials here explaning how to make yourself have permissions whilst running the live cd, and these dont work you have any suggestions for changing permissions and allowing for me to backup my stuff so I can re-install? Thanks, NDG. – user291652 May 30 '11 at 11:17
in the live cd environment you should be able to use sudo. for example, you could open a terminal and type sudo gnome-open /home which will open a file-explorer window with root permissions. – netbrain May 30 '11 at 11:23
That works for my internal file system, however I am unable to copy files to another hard drive as they are read only - I tried opening my external drive with the same command, however it remains read only...any suggestions? Thanks, NDG. – user291652 May 30 '11 at 11:39

I had a similar problem. The solution ended up being moving the old .Xauthority out of the way and let the system create a new one on the next login. Don't ask me why but it worked...

share|improve this answer

Check to see if the .profile file in your home folder exists. If you changed the .profile file, you may need to comment out the changed lines.

share|improve this answer
Bingo. I had the same OP's problem, and now it's solved thanks to your tip. Thanks! – Somebody still uses you MS-DOS Nov 23 '11 at 23:03

I had the same symptom. The cause was also as mentioned above in the ~/.profile file. I had installed Byobu and checked to start Byobu at login. Later I uninstalled Byobu without unchecking "start Byobu at login". So the entry of Byobu was still in the ~/.profile. After commenting out that entry I could login regularly.

share|improve this answer

Could it be like some kind of xorg failure? Check to see if there is a xorg.conf under /etc/X11/ if there is, back it up to something .bak and remove it, then try again to see if it fixes things. Try Ctrl + Alt + F1 to enter tty1 to execute your commands. You might also want to stop GDM (sudo service gdm stop), do the changes, then restart GDM (sudo service gdm start) to see if it works, or if it brings any error messages.

share|improve this answer

Try this:

share|improve this answer
Could you possibly para-phrase the instructions in addition to posting a link. – Marco Ceppi May 30 '11 at 14:31
I didn't want to post a possible systemhack, just posted a link to a possible solution, man. – sh4d0w May 30 '11 at 19:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.