Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to have a fresh install of latest Ubuntu Desktop 14.04 in my laptop running on Windows 8 using USB iso image.

I am careful on all things like :

  1. BIOS settings - External USB Flash drive - 1st Priority etc.
  2. Tried Directly to BOOT from USB option as of advanced windows 8 option.

Still, I am facing the error

Operating System Not Found

Any suggestions, geeks.

share|improve this question
    
How did you put the ISO on the USB drive? –  Louis Matthijssen May 3 at 10:47
    
Sir, I put the ISO as a bootable one which contains folders & subfolders. –  Mohanraj Subramaniam May 4 at 15:22

2 Answers 2

Yesterday I tried to make a clean installation of 14.04.1 on a Lenovo X121e, and got "Operating System Not Found" - no grub.

So I started over again with an old Ubuntu 10.04.2.LTS i386, that I still had around. That installation worked, grub now on board, and then I installed the 14.04.1 amd64 again, choking down the 10.04 partition to a few GB. And then the 14.04 started nicely.

It is not a clean solution, but got me through the problem. It might also work to upgrade the 10.04 to 14.04, but I didn't bother to try that. (The "software update" of 14.04 from 13.whatever was not a satisfying experience).

So obviously there is an essential feature in 10.04 ("starting the operating system") that is missing in 14.04, I guess someone should run a "diff" on these two ;-).

hilmer_B

share|improve this answer

The USB has problems booting under an EFI environment. Usually, this results in a simple GRUB prompt. What you may try doing instead is enabling the CSM of your EFI (System/BIOS setup). On mine (Lenovo), this is an option called something like "Boot mode" with the options of UEFI and Legacy. In my case, I would change this to Legacy. Then, your USB should be able to boot depending on how you made the USB in the first place (i.e. unetbootin doesn't work).

However, since the install will be from Legacy mode, it will then only be bootable in Legacy mode, meaning you won't be able to boot Win 8.

In order to fix this, you have to enable EFI boot in Ubuntu after installation:

  1. From a terminal: sudo apt-get install grub-efi
  2. Reboot, change the UEFI (BIOS) back to UEFI mode (as opposed to Legacy)
  3. You should then be presented with a menu allowing you to boot several options including Ubuntu and Windows
  4. A few buggy UEFI implementations can cause issues. If you run into any problems, I can try to guide you form there.

OK, so it appears that you must have installed Ubuntu in legacy (non-UEFI mode). In order to fix this, follow these steps:

  1. Boot up Ubuntu from Legacy (non-UEFI) mode.
  2. From a terminal: sudo apt-get install grub-efi
  3. Reboot and enter Setup ("BIOS") via F1, Delete, F12, etc.
  4. Go to the "Boot" tab and move "Ubuntu" to the top.
  5. Reboot and you should see the GRUB menu with options for Ubuntu as well as Windows.
share|improve this answer
    
Hello Githlar sir, I followed all things upto step 3. When I restart, two things happen. First one, If UEFI mode,Ubuntu is not showing in grub. Second one, if in legacy mode, Windows is not showing in grub. How to resolve to display both ubuntu & windows in UEFI mode,then to select as our wish? –  Mohanraj Subramaniam May 4 at 17:00
    
I updated my answer. –  Githlar May 4 at 20:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.