Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading from lubuntu 13.10 to 14.04 the fan of my laptop seems to run much more often than in 13.10. When it runs, it doesn't run continously but starts and stops every second.

fwts fan results in

Results generated by fwts: Version V14.03.01 (2014-03-27 02:14:17).

Some of this work - Copyright (c) 1999 - 2014, Intel Corp. All rights reserved.
Some of this work - Copyright (c) 2010 - 2014, Canonical.

This test run on 12/05/14 at 21:40:13 on host Linux einstein 3.13.0-24-generic
#47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 x86_64.

Command: "fwts fan".
Running tests: fan.

fan: Simple fan tests.
--------------------------------------------------------------------------------
Test 1 of 2: Test fan status.
Test how many fans there are in the system. Check for the current status of the
fan(s).
PASSED: Test 1, Fan cooling_device0 of type Processor has max cooling state 10
and current cooling state 0.
PASSED: Test 1, Fan cooling_device1 of type Processor has max cooling state 10
and current cooling state 0.
PASSED: Test 1, Fan cooling_device2 of type LCD has max cooling state 15 and
current cooling state 10.

Test 2 of 2: Load system, check CPU fan status.
Test how many fans there are in the system. Check for the current status of the
fan(s).
Loading CPUs for 20 seconds to try and get fan speeds to change.
Fan cooling_device0 current state did not change from value 0 while CPUs were
busy.
Fan cooling_device1 current state did not change from value 0 while CPUs were
busy.

ADVICE: Did not detect any change in the CPU related thermal cooling device
states. It could be that the devices are returning static information back to
the driver and/or the fan speed is automatically being controlled by firmware
using System Management Mode in which case the kernel interfaces being examined
may not work anyway.


================================================================================
3 passed, 0 failed, 0 warning, 0 aborted, 0 skipped, 0 info only.
================================================================================


3 passed, 0 failed, 0 warning, 0 aborted, 0 skipped, 0 info only.

Test Failure Summary
================================================================================

Critical failures: NONE

High failures: NONE

Medium failures: NONE

Low failures: NONE

Other failures: NONE

Test           |Pass |Fail |Abort|Warn |Skip |Info |
---------------+-----+-----+-----+-----+-----+-----+
fan            |    3|     |     |     |     |     |
---------------+-----+-----+-----+-----+-----+-----+
Total:         |    3|    0|    0|    0|    0|    0|
---------------+-----+-----+-----+-----+-----+-----+

Here is the output of lsmod

lsmod
Module                  Size  Used by
i8k                    14421  0 
zram                   18478  2 
dm_crypt               23177  0 
gpio_ich               13476  0 
dell_wmi               12761  0 
sparse_keymap          13948  1 dell_wmi
snd_hda_codec_hdmi     46207  1 
snd_hda_codec_idt      54645  1 
rfcomm                 69160  0 
arc4                   12608  2 
dell_laptop            18168  0 
bnep                   19624  2 
dcdbas                 14928  1 dell_laptop
bluetooth             395423  10 bnep,rfcomm
iwldvm                232285  0 
mac80211              626511  1 iwldvm
snd_hda_intel          52355  3 
snd_hda_codec         192906  3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
snd_hwdep              13602  1 snd_hda_codec
snd_pcm               102099  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc         18710  2 snd_pcm,snd_hda_intel
snd_seq_midi           13324  0 
snd_seq_midi_event     14899  1 snd_seq_midi
snd_rawmidi            30144  1 snd_seq_midi
coretemp               13435  0 
kvm_intel             143060  0 
kvm                   451511  1 kvm_intel
snd_seq                61560  2 snd_seq_midi_event,snd_seq_midi
joydev                 17381  0 
serio_raw              13462  0 
iwlwifi               169932  1 iwldvm
pcmcia                 62299  0 
snd_seq_device         14497  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              29482  2 snd_pcm,snd_seq
lpc_ich                21080  0 
cfg80211              484040  3 iwlwifi,mac80211,iwldvm
yenta_socket           41027  0 
pcmcia_rsrc            18407  1 yenta_socket
pcmcia_core            23592  3 pcmcia,pcmcia_rsrc,yenta_socket
binfmt_misc            17468  1 
snd                    69238  17 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_idt,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_seq_midi
soundcore              12680  1 snd
parport_pc             32701  0 
mac_hid                13205  0 
ppdev                  17671  0 
lp                     17759  0 
parport                42348  3 lp,ppdev,parport_pc
firewire_ohci          40409  0 
psmouse               102222  0 
sdhci_pci              23172  0 
sdhci                  43015  1 sdhci_pci
firewire_core          68769  1 firewire_ohci
crc_itu_t              12707  1 firewire_core
ahci                   25819  2 
libahci                32168  1 ahci
i915                  783485  2 
wmi                    19177  1 dell_wmi
i2c_algo_bit           13413  1 i915
drm_kms_helper         52758  1 i915
e1000e                254433  0 
drm                   302817  3 i915,drm_kms_helper
ptp                    18933  1 e1000e
pps_core               19382  1 ptp
video                  19476  1 i915

I tried one answer to the similar question: loud fan on Ubuntu 14.04 and created a /etc/i8kmon.conf like the following:

# Run as daemon, override with --daemon option
set config(daemon) 1

# Automatic fan control, override with --auto option
set config(auto) 1

# Status check timeout (seconds), override with --timeout option  
set config(timeout) 2

# Report status on stdout, override with --verbose option
set config(verbose) 1

# Temperature thresholds: {fan_speeds low_ac high_ac low_batt high_batt}
set config(0) {{0 0} -1 55 -1 55}
set config(1) {{0 1} 50 60 55 65}
set config(2) {{1 1} 55 80 60 85}
set config(3) {{2 2} 70 128 75 128}

With this setup the fan goes on even if the temperature is below 50 degree celsius (I don't see a pattern). However I get the impression that the CPU got's hotter in average than without this file.

What changes from 13.10 to 14.04 may be responsible for this?

If this is a bug, for which package I should report the bug?

share|improve this question
    
I'm experiencing the same annoying problem. I have a Dell Latitude E5420 and it had never been noisy until I did the upgrade. –  Ricky Robinson May 12 at 10:01
    
My laptop with this problem is a Dell Latitude E6400 –  student May 12 at 12:37
    
    
Check the answer in the "Asus fan" question for information on running the Ubuntu firmware test suite –  bain May 12 at 17:00
2  
It is not Asus specific, check the upstream bug report bugzilla.kernel.org/show_bug.cgi?id=71711 –  bain May 25 at 14:22
show 5 more comments

4 Answers 4

This is a bug in the Linux kernel. However, according to https://bugzilla.kernel.org/show_bug.cgi?id=71711, the top of the page says "RESOLVED PATCH_ALREADY_AVAILABLE", meaning that there is a fix. I think it has been fixed in Linux kernel 3.14.

share|improve this answer
    
Thanks. Will the 3.14 kernel be part of the ubuntu 14.04 repositories in some weeks or do I have to update manually (or wait for ubuntu 14.10)? –  student May 25 at 14:55
    
I am not sure if the 3.14 kernel fixes this, but if it does it must be installed manually and things may go wrong when updating the Linux kernel. Do a bit of research, or run a GNU/Linux distro live that uses kernel 3.14. If you decide that you do want to update the kernel (even though I am not sure if it will help), go to kernelnewbies.org. It's a site that helps people that are not experienced in installing and updating the kernel do it successfully. –  FuzzyToothpaste May 26 at 23:52
    
Although the problem is not solved yet, you get the bounty for pointing out this bug! –  student Jun 1 at 14:28
add comment

What changes from 13.10 to 14.04 may be responsible for this?

If I have to guess, it would be the kernel. The kernel is responsible for most power related stuff (fan, batteries, devices, large etc.) so is the usual suspect. If it isn't then there's no much where to dig from, some -firmware package, perhaps, but in these cases is for privative modules.

If this is a bug, for which package I should report the bug?

ubuntu-bug linux

This would call Ubuntu bug reporting helper and fill out most of the required information.

share|improve this answer
add comment

I'd recommend installing fancontrol from the 14.04 repositories, and then configure it by running pwmconfig as root.

After installing fancontrol I was able to reduce my server's noise from "annoying" to "barely perceptible" with only a small increase in temperature. I monitor temperatures and fan speeds remotely and can confirm it reacts to temperature increases.

Without that I think you're probably relying on the controls built in to your hardware (my laptop has three settings for fan control, and one of them alternates between full on and stopped which seems to be what you're experiencing.

share|improve this answer
add comment

How about this utility?

Worked nicely on my Acer Aspire 5742G with Intel Core i3 processor, 8 GB RAM, 640 GB HDD and nVidia GeForce 520M with 1GB memory running Ubuntu Desktop 14.04 LTS.

share|improve this answer
    
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. –  RobinJ May 30 at 18:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.