Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently bought a shiny new Lenovo Yoga 2 Pro and I want to dual boot it with Ubuntu for studying purposes. Its built-in OS is Windows 8.1 and it has a 256GB SSD.

I've made a separate 90GB partition just for Ubuntu and a live USB to install it.

The first time everything seemed to work great, I solved the wifi issued by blacklisting ideapad_laptop, the installation went flawlessly and Ubuntu worked fine.

When I got up the next morning and turned on my laptop it booted into Windows right away without ever showing the GRUB menu. So I tried to reset, and checked my partitions with the Disk Manager and everything looked fine. Since I couldn't find a solution online I went ahead and formatted the partition to try and install again. This time and every time since, the installation was aborted and I got a fatal error saying:

Unable to install GRUB in /dev/sda
Executing `grub-install /dev/sda` failed.
This is a fatal error.

Can anyone please suggest a solution to this problem? If any further information is needed I would be happy to provide it. Thanks.

When installing I get the following in details:

ubuntu kernel: [ 1946.372741] FAT-fs (sda2): error, fat_get_cluster: invalid cluster chain (i_pos 0).
ubuntu grub-installer: error: Running 'grub-install --force failed.
share|improve this question
    
possible duplicate of Ubuntu on Lenovo Yoga 2 Pro – rubo77 May 26 '14 at 9:31
    
In addition the the answers below, what ended up finally getting the grub partition to install correctly again for me was, when manually formatting partitions, creating a partition formatted as UEFI and selecting that as the destination for grub. I was otherwise following the instructions on this answer. – Milo Price May 6 '15 at 20:18

10 Answers 10

I just had this problem installing Ubuntu 14.04 from a USB stick to a hard drive.

The problem was the USB stick was /dev/sda, installing to the hard drive /dev/sdb

Even though the installer knew to install to /dev/sdb, it then tried to install grub to the MBR on /dev/sda, and failed. The workaround was to go back to the menu, try again, say NO to "automatically install to MBR of first hard drive" and manually tell it /dev/sdb.

Then everything worked.

share|improve this answer
    
Can you explain what you mean by "the USB stick was dev/sda"? – CodyBugstein Jan 12 at 23:07
    
Different drives can be mounted to any /dev/sd? directory. It is possible for a flash drive to be mounted under /dev/sda. – Brian Sizemore Jan 14 at 3:01
    
Don't forget the "/dev/" part, so it should be exactly "/dev/sdb", not just "sdb". – Max Malysh Mar 13 at 17:31
up vote 3 down vote accepted

Solved
I finally got it working, not sure which of the following did the trick but I:
1. Disabled Lenovo Fast Boot in BIOS.
2. Disabled Secure Boot in BIOS.
3. Booted from Live USB.
4. In boot menu Added backlight=vendor in "Try Ubuntu" configuration text just before "quiet splash".
5. Chose Try Ubuntu.
6. In terminal ran sudo rmmod ideapad_laptop to enable wifi.
7. Ran installation and chose to install updates during installation.
8. EFI partition was selected automatically so I assigned 9700MB for swap space and 80GB for Ubuntu.
9. After installation completed added backlight=vendor to etc/default/grub before "quiet splash".
10. Blacklisted ideapad_laptop to enable wifi.
11. Works fine so far. Thanks to everyone for the help!

share|improve this answer
  1. Check installation media for corruption
  2. Check BIOS and disable Secure boot
  3. Disable Lenovo fast boot

I assume you are installing in UEFI mode, so it might be nescessary to unlock System lock in BIOS. If neither works, I would assume that problem lies in dual boot. I myself am running Ubuntu on Y2P as I type without any problems.

As for blacklisting ideapad_laptop module, you may want to check github.com/pfps/yoga-laptop, as there are some Y2P specific drivers. Still work in progres tho.

share|improve this answer
    
Thanks for your reply, What do you mean by unlocking system lock in BIOS? – vicban3d May 3 '14 at 10:05

I have the same laptop and for me everything works fine - but I installed the grub loader into the already existing EFI partition, which had the index 2 at the end of its name - it certainly wasn't the sda partition though, which was chosen by default. (So I chose my partition for installation above and below, there was the possibility to change the partition for grub installation.) I used an SD card for installation and started it in UEFI mode, because Windows 8.1 was pre-installed that way, too. (I'm sorry if I'm expressing this in a wrong way, but I only know about all this from reading in different forums before installing Ubuntu 14.04 about three days ago.) Anyway, everything works fine if you do it this way. Start installation medium in UEFI mode, choose the partition freed for the installation, install grub into the existing EFI partition.

Oh, and also, I didn't really have to change anything in the BIOS, I had disabled fast boot before and left it that way. It automatically changed something else, I can look that up again, if you want to know.

share|improve this answer

Just wanted to share my experience and confirm the above answer that during my ubuntu server installation the installer tried to install the Grub to /dev/sda which is the usb stick thus I got the

Unable to install GRUB in /dev/sda

Changing the path to /dev/sdb solved the problem

share|improve this answer

I got the same problem when installing ubuntu 15.10 desktop ( dual boot on separate partion in Lenovo G40-45 laptop where windows 10 is already installed and activated ). I have already disabled the secure boot(As per my earlier experiences with dual boot - linux and windows. I have tried many solutions given in askubutu itself and many times.

Finally I decided that I will try with secure boot enabled ( as I expect things have improved since 14.xx ). AND IT IS SUCCESS !!! -- without any other adjustments ( and with out internet connection ).

(Edit) (I have installed the windows 10 while secure boot is disabled and then installed the Ubuntu while secure boot is enabled).

share|improve this answer

I had a plethora of devices on a bare install and got this on 12.04 (last alternate manual install). Rather than track down where you specify to GRUB, I just acquiesced and moved the boot SSD to the sata-0 port so it would show up as sda.

share|improve this answer
    
Someone should clarify whether Lenovo Yoga 2 Pro has actually two SATA slots for swapping the storage disk's position. I searched Yoga 2 Pro has only one SATA slots, so this answer is unlikely? – clearkimura Dec 1 '15 at 10:37

I just want to add to the discussion here. I too had the infamous “Unable to install GRUB in /dev/sda” when trying to install Ubuntu (not dual-boot) in my new build. Every boot option as described above would not work for me. I had to disconnect my SSD and all USB devises so that Ubuntu would only recognize the 1T HDD for installation. I hope this helps.

share|improve this answer

I had a similar problem. What I did was to leave the installation as it was, then I made sure my drive was in UEFI mode and booted from a live CD and installed boot-repair. To do this I had to add the yannubuntu repository and then download it with apt-get. This was done the following way:

sudo apt-add-repository ppa:yannubuntu/boot-repair

sudo apt-get update

sudo apt-get install boot-repair

boot-repair

Then, when the program was launched, I checked all the options in Advanced Options -> Main Options and clicked Apply.

share|improve this answer

Ran into this very issue while installing on a Poweredge with scsi raid. I found that pulling out the USB drive prior to installing GRUB did the trick.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.