Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had a problem with the keyboard layout changing from PT (I'm Portuguese) to EN automatically with the last Ubuntu updates in Ubuntu 13.10. After Ubuntu 14.04 came out, I formatted my computer and installed the new version.

After that I haven't had any problems until the recent Ubuntu base update 2 or 3 days ago, when I started having the same problem again. I even removed the English keyboard from the Keyboard configurations, left only the Portuguese one, but still, every time I reboot my PC I get the keyboard configured for EN, despite Ubuntu displaying the contrary?

How can I remove this? I don't want to format the PC again and I'm getting really tired of this problem, since it looks like many Portuguese/Brasilian Ubuntu users are having the same problem.

share|improve this question

closed as off-topic by Braiam, Lucio, Eric Carvalho, psusi, Avinash Raj May 18 at 23:24

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, Lucio, Eric Carvalho, psusi, Avinash Raj
If this question can be reworded to fit the rules in the help center, please edit the question.

    
This could be a similar issue to this problem askubuntu.com/questions/367209/… The solution worked for me (resetting it back to UK layout) might work here. –  ChrisD May 15 at 16:55
1  
There is a relevant bug report here (I think) bugzilla.gnome.org/show_bug.cgi?id=729423 and bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/… –  Rmano May 15 at 17:06
    
It is not off-topic since the version in question is not a development version and was supposed to be not only stable, but Long-Term Support. Trying to tag it as off-topic seems like a political move. –  7hi4g0 May 23 at 19:55
    
Also see: askubuntu.com/questions/362973/… –  Seth May 23 at 20:20
    
As this is a question for a workaround and no bug report I don't really understand why it has been closed as off-topic. –  Sebastian Jun 13 at 18:39

2 Answers 2

Found a solution for me.

Keyboard configuration

On terminal:

$ # If dconf-editor is not already installed
$ sudo apt-get install dconf-editor
$ dconf-editor

When the program opens do the following:

  • navigate to desktop.ibus.general enter image description here
  • remove 'xkb:us::eng' from both engines-order and preload-engines enter image description here

Works for me on Brazilian Portuguese, hope that works for you.

share|improve this answer
    
It worked for some time, but after a while it added the english layout automatically on both engines-order and preload-engines. –  Balder May 23 at 19:10

Looks to be a known Bug in 14.04.

What you can try is reconfiguring the keyboard data via the Terminal.

sudo dpkg-reconfigure xkb-data

Click on the Keyboard Icon on the top and select your keyboard.

I know this is a hit or miss solution and I’ll keep searching for that article that references these steps to see if others have had success.

Edit

I Located the article i was thinking of - keyboard layout EN after boot

share|improve this answer
1  
unfortunately the problem persists... I can't understand why they would release a "stable version" with these bugs, when they had been informed about them in the 13.10 and 13.04 versions. –  user277167 May 2 at 22:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.