Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a Vaio laptop that used to work with 13.10. I did an upgrade to 14.04 and since then it does not want to boot any more, that is it doesn't seem to reach grub: I'm stuck on a "BIOS" screen telling me "Windows (sic) failed to load : recovery solution, contact vaio,..."

Running boot-repair does not help (http://paste.ubuntu.com/7309686/)

I wiped out my SSD and did a fresh install of 14.04 (default options) : nope. Also tried fresh install 13.10 : nope (even though boot-repair tells me "no error" this time)

I tried Fedora : success!! (but I'd prefer Ubuntu)

I tried 14.10 again but using a Legacy boot this time instead of UEFI : success but it takes 14s to boot compared to the previous 3s! That's not really satisfying!

My questions:

  • by "wipe out" I mean delete MBR and GPT informations by writing 0s on the disk (dd if=/dev/zero ...). Could it be an issue?
  • any ways to know what's wrong during the boot process BEFORE grub is started?
  • can it be related to a BIOS/EFI bug in the firmware?
  • Any idea what could be the problem?

**Update : **

I checked where grub was installed but I couldn't find it (see this ) ?! I dumped the 512k at start of the disk and ... there are all 0s !? It should contain grub no?

Thanks guys

share|improve this question

1 Answer 1

If by "512k at start of the disk" you mean 440 bytes, then no, GRUB should not reside there on an EFI-booting computer. On such a computer, the boot loader lives in the EFI System Partition (ESP) as ordinary file(s). You've got such a partition (/dev/sda1), but there's no evidence of GRUB installed on it. You may want to check that manually using an emergency system -- look for a directory called EFI/ubuntu on that partition. On an Ubuntu install, it will normally have a file called grubx64.efi, and probably another called shimx64.efi. If those files aren't present, then your EFI boot loader has failed to install. In this case, you have a number of options:

  • Install GRUB manually. This can be done with emergency discs, using the procedure described here (although that's a rather inefficient procedure).
  • Install GRUB automatically. The Boot Repair tool can usually fix this problem relatively painlessly; however, you must be sure to boot it in EFI mode. Once you've booted, check for the presence of a directory called /sys/firmware/efi. If it's present, you've booted in EFI mode and may proceed. If not, then you should check how you boot and find a way to boot into EFI mode. (Unfortunately, how to do this varies from one system to another, so I can't provide a simple set of instructions.)
  • Use my rEFInd boot manager: Download a USB flash drive or CD-R image, prepare the medium, and boot with it. You should see at least one option to boot Ubuntu. If it works, install the Debian-package version of rEFInd. It will then take over boot manager duties from GRUB.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.