Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just started using Linux and as such do not have a proper knowledge of how to use the command line and all of those sorts of things, so please try to bear with me :).

I have been able to connect to my house WiFi since I first started using this computer, but for some reason after a restart, i could no longer connect to WiFi as when I am asked for a password I can only enter one which is either 5 or 14 characters long.

I looked up a number of guides on the subject, this seeming to fit the description perfectly:

Wifi only accepts passwords of 5 or 13 characters

I have tried since then changing my wireless setting for my network back to WPA, which it allows me to do. However when I try to connect to the internet, it gets stuck in the same place, and if I try to view it under my wireless connections, my computer will for some reason have created a new log of this network.

By this I mean, I will have changed the settings to WPA on "My-WiFi", and when it tries to connect it will create a new WEP connection called "My-WiFi 1".

Tried a few fixes but none have worked :/.

share|improve this question
Can other computers connect to that network? – Alex May 2 '14 at 18:33
Yeah, there's no problem with the internet. Its that i can't get the network manager to accept the correct password length. – user277062 May 3 '14 at 16:59
Check the encryption type used on those PCs and make sure you select the same on the troublesome PC. If that doesn't work, my suggestion is to try a different network manager. I suggest wicd. The procedure would be: 1. Connect the computer to the internet via an ethernet cable. 2. Uninstall network-manager, backing up any passwords. 3. Install wicd. If it works, keep it, if not, uninstall it and install network-manager back. Disclaimer: I use Debian. I don't know how Ubuntu handles network managing. It should all run smoothly, but issues may occur due to uninstalling network-manager. – Alex May 4 '14 at 4:19
What device (and model) is providing your wifi (your router or gateway)? I used to have this problem. When I got it to work, I went into the wifi manager and got the hex version of the password and used that on subsequent logins. For some reason, that worked. You may be able to get this from one of your other computers that can login. – Joe May 8 '14 at 6:16
You may have to go into network manager and delete the connections which use WEP. While you're connected via Ethernet (cable), go into your router's home page (usually with an IP address like, but it varies by brand) and make sure it is setup (under Wireless Connections) to use WPA with the password of your choice. Copy that password by selecting it and copying it into your clipboard. Disconnect the cable and try to connect wirelessly, paste the password in so no possibility of typos, etc. I have had problems like this a few times. I just keep trying and eventually it works. – Joe May 8 '14 at 6:32

Please Update with Wireless Router model and any pertinent info regarding that device. For now, I'm assuming Your wifi router can in fact provide other forms of encryption.

The first thing we should know is what your device is named:

$sudo iwconfig

it gives similar output to ifconfig. What we care about is the device name. lets pretend it is wlan0. next, do $sudo iwlist wlan0 auth

alternatively, do

$sudo iw list

this will tell you what authentication protocols your wlan0 device supports. If there is something besides WEP available, Please tell us your preferred Authentication method, out of which your device supports. I will update my answer accordingly.

share|improve this answer
I get confused around sudo iwlist, and sudo iw list. oh well do it either way – j0h Jan 21 '15 at 5:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.