Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install PostgreSQL on my VPS running Ubuntu 12.04. A month ago I success installed Postgresql 9.3 but I forgot the Postgis extension, after I installed the Postgis there come a problem everytime I tried to restart the postgresql service. The error code is:

Cannot find /proc/version - is /proc mounted?
Error: pid file is invalid, please manually kill the stale server process

Please help me, I already tried any given tutorial and using several repo and PPA. I also clean format my server but the same error message always come. It came everytime I tried to

sudo service restart postgresql

regards

UPDATE: Here are my terminal respond from PuTTY after "ls /proc"

root@hostname8327:~# ls /proc
1      10437  4409  660      cpuinfo      meminfo     sysrq-trigger
103    10438  4410  685      devices      modules     sysvipc
10407  109    4411  7054     fairsched    mounts      uptime
10411  115    4412  7055     fairsched2   net         user_beancounters
10412  2      444   7056     filesystems  partitions  version
10413  226    465   725      fs           self        vmstat
10414  3      498   729      kmsg         stat        vz
10425  395    500   cgroups  loadavg      swaps
10436  4407   6468  cmdline  locks        sys
share|improve this question
    
The problem is with something on your computer, not PPAs or packages. If you do ls /proc, do you get roughly 300 directories, or do you get nothing or an error? (Don't paste the output) –  saiarcot895 May 2 at 12:08
    
What's the output of ls /proc ? –  Craig Ringer May 3 at 4:46
    
I'm sorry @saiarcot895 I'm not really understand about what you mean for "roughly 300 directories" because I'm a new user of Linux. I updated my post with the output of "ls /proc" –  iqnaul May 3 at 13:09
    
@CraigRinger Hi, I updated my post about the output of "ls /proc" –  iqnaul May 3 at 13:10
    
How'd you install PostgreSQL and from where? This looks ... odd. –  Craig Ringer May 4 at 0:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.