Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have NetGear ReadyNAS Business Pro with 6 Place for 6 Disks

I did a hack the box (basically it is a normal PC with Intel CPU)

I upgraded the CPU and I used the ReadyNAS OS 6 (which is Debian based) which uses Linux RAID and Btrfs. Note:the the Box has a build in USB Disk with 128MB size and this disk used for /boot

worked all fine many updates came and had no problems at all ... til the last one where it stopped booting because of something went wrong with the boot .... bal bal bal

now I want to go to something I really would like to do installing Ubuntu (I used Lubuntu) the Box has a VGA out and USBs so no problems to connect a monitor and a keyboard/mouse

booted Lubuntu from a USB-CD drive worked fine found all the disks not the RAID/Btrfs partitions

what I did after i booted the Live CD (Lubuntu) I installed mdadm (apt-get install mdadm) then (sudo mdadm --assemble --scan) and it did find RAID Disk and all cool

I got /dev/md/0 around 4.4GB Btrfs /dev/md/1 around 2GB SWAP /dev/md/0-data around 9GB Btrfs

and I can see my files and all the backups

then I decided to install Lubuntu

the /boot will be on the /sdd1 128MB Build in USB disk (Ext4 Format on)

the / will be on /dev/md/0 (Btrfs Format on)

the SWAP will be on /dev/md/1 (SWAP allready no format needed)

the /data will be on /dev/md/0-data (Btrfs without formating)

all went well

after install tried to boot the system but it seems it failed to mount the RAID disks!

what steps I should do? I know I might to add/edit something to the /boot to make is start the RAID software!

share|improve this question
1  
1. Btrfs has built-in RAID and multiple device management, in general the mdadm is unnecessary. By default, btrfs stores 2 copy of filesystem metadata and 1 copy of data. You can set 2 copies of data either by formatting with mkfs.btrfs -d raid1 (see man page for more options), or by doing btrfs filesystem balance -d raid1 after creation (even during normal use; see man page for more info). –  ignis May 3 at 5:11
1  
2. Btrfs has gained a lot of bugfixes and performance since 12.04, so you'd better install the HWE stack to get the 14.04 kernel, or use 14.04 (which is 3-years supported LTS, by the way). Either way, Lubuntu 12.04 is not LTS and has reached end-of-life, which means: the Ubuntu core still gets updates, the LXDE graphical environment does not (I don't know whether that could be relevant on your setup). –  ignis May 3 at 5:11
2  
3. *Ubuntu can boot from a btrfs without the need for /boot. –  ignis May 3 at 5:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.