Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

As title suggests, I upgrade to 14.04. After that browser informed:

...can't find the server at "host name"...

So the name server seems not to work. How should I fix the problem?

share|improve this question
What's the output of nslookup – Louis Matthijssen May 2 '14 at 5:48
output is ;; connection timed out; no servers could be reached – Jukka May 2 '14 at 5:52
Could you post the output of nm-tool? – Louis Matthijssen May 2 '14 at 5:56
What do you want to know? for dns it says dns: dns: Last one is gw not dns – Jukka May 2 '14 at 6:06
Does nslookup work? – Louis Matthijssen May 2 '14 at 6:27
up vote 2 down vote accepted
  1. Edit /etc/resolvconf/resolv.conf.d/head:

    sudo nano /etc/resolvconf/resolv.conf.d/head
  2. Add the following line to the top of the file:

  3. Save the file:

    CTRL + X

  4. Restart your network (or reboot your pc):

    sudo service networking restart
share|improve this answer
Before making this change, I restarted the computer and tried to load some web page. Everything worked fine. So the information has not disappeared. – Jukka May 2 '14 at 12:02
That's strange, but cool that it's working now. – Louis Matthijssen May 2 '14 at 12:04
Before making this permanent change, I tried to restart my network (as stated above). Result was stop: job failed while stopping start: job is already running networking – Jukka May 2 '14 at 12:06

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.