Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I updated to Ubuntu 14.04 and found that the primusrun command no longer works, so ditched bumblebee in favour of nvidia-prime. This lets you switch video card from nvidia-settings rather than running through the command line (I prefer the old method, but want the primus performance).

The problem is that after switching to Intel from nvidia-settings, I can no longer open it up again to switch back to the nvidia card. When I open nvidia-settings I get a segmentation fault (according to the terminal).

Is there any way to open nvidia-settings switch back? I would like the ability to be able to switch between the two since having the nvidia card on all the time kills my battery and heats up the laptop a lot.

share|improve this question

1 Answer 1

up vote 7 down vote accepted

This is a bug (LP #1214508).

You can switch using:

sudo prime-select intel
sudo prime-select nvidia

Also, Bumblebee is still supported so you can install it if you prefer. You'll have to remove nvidia-prime then as you can't use both.

share|improve this answer
    
Yes, that worked (after logging out and back in). Thank you! I do prefer using bumblebee, but after the update to 14.04, only optirun worked and not primusrun (everything I ran gave a segmentation fault). Ideally, I would like to return to using the primusrun command, but if this is the only way I can get the extra performance, then I'll use this. –  user270340 May 2 at 14:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.