Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Actually, that's slightly misleading, but titles ought to be simple. I have a splash screen: -For about two seconds during boot, right before the login screen appears. -During shutdown.

During boot I just see the same purple as used by grub. (Edit: when grub's background is changed, so is the one during boot, so grub seems to be... covering it?)

This has happened since I installed 11.04. 10.04 and 10.10's splashed worked fine for me.

share|improve this question
    
The boot process in 11.04 brings up the login screen a lot faster than the previous release. Is the complaint that this doesn't leave much time to see the splash screen? –  James Henstridge May 30 '11 at 1:39
    
Nope, booting still takes about 30 seconds. –  Vallery May 30 '11 at 1:48
add comment

4 Answers

I finally found the solution for me.

First i followed the instructions you can find in the article "how to fix your Ubuntu splash screen".

Then i had to change manually the resolutions in /etc/default/grub to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=800x600-24, mtrr=3, scroll=ywrap" ;  

(do not forget sudo update-grub afterwards).

Why, i do not know. In 10.10 it was 1280x1024-24.

I think it is with the changes in the Ati driver that cames with 11.04. But i have a nice splash screen at boot time and logoff time now.

share|improve this answer
add comment

For me the fix was found in comment #3 of this thread.

I just had too remove "vt.handoff=7" from /etc/grub.d/10_linux (just search/delete) and then run sudo update-grub afterwards.

share|improve this answer
    
That fixed it for me, thanks! –  handuel Apr 1 '13 at 20:18
add comment

I finally found the solution for me.

First i followed the instructions you can find in the article "how to fix your Ubuntu splash screen". http://kyleabaker.com/#search=plymouth

Then i had to change manually the resolutions in /etc/default/grub to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=800x600-24, mtrr=3, scroll=ywrap" ;

(do not forget sudo update-grub afterwards).

Why, i do not know. In 10.10 it was 1280x1024-24.

I think it is with the changes in the Ati driver that cames with 11.04. But i have a nice splash screen at boot time and logoff time now.

share|improve this answer
add comment

Instal cryptsetup has no influence at all. I have found a partial solution at /usr/share/doc/plytmouth : readme. This is because the driver that permits high-color graphics tends to cause issues with suspend and resume, and we opted to prefer that working.

For nVidia and ATI users, the default "nouveau" and "radeon"
drivers are Kernel Mode Setting enabled, but do not always
provide 3D capability at the current time.  By switching to
using the restricted/non-free nvidia-glx or fglrx drivers,
you will gain 3D capability at the loss of a high-color
splash screen.

You can however chose to enable high-color (and resolution) console if you find it doesn't affect suspend/resume for you, or you don't use that feature.

There are various methods of doing this, the most robust is the following four steps:

Append video=vesafb to the GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub sudo update-grub

echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash sudo update-initramfs -u

At the moment i have splash screen in low resolution at startup (always better than black screen) - and normal splash at logout.

share|improve this answer
    
Doing this worked for a few boots, but now the screen is simply shutting off during boot. –  Vallery May 31 '11 at 21:02
    
Edit: Ok, it seems to work fine about 50% of the time. The other half the screen shuts of during boot, but turns back on when fully booted. –  Vallery Jun 1 '11 at 3:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.