Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Dear Ubuntu community,

I've installed LTS 12.04 recently as XP extented support ceased. I've used a CD for the installation as it seems my PC cannot boot from USB. After 2 weeks of enjoying Ubuntu, I've updated some programs (the ones suggested by the update manager) and installed 2 image/photo editors (darktable and another one).

The update manager asked me to reboot, which I have done. Since then, it's impossible to reboot. The boot goes at different stage everytime, sometimes it goes as far as the pixelated 12.04 screen with the 4 dots showing some progress.

Everytime it displays a few lines of text that do not make sense to me and present me with the cursor, but I can't type anything.

Also, my CD drive has died so I can't read the installation CD.

Is there a way I can fix this without having to replace my CD-rom drive ?

Thanks for your help.

ThorOdin

PS: I only have Ubuntu 12.04 installed. No dual boot.

share|improve this question
    
Please report the exact error message(s) that you see. Or upload a READABLE photo. –  ignis May 1 at 18:54
    
Ok, I'll take a snapshot, or a few since error message changes from reboot to reboot. –  ThorOdin May 1 at 19:54

1 Answer 1

to give you a real help, these error-lines shown would be really important!

The error-output shown can tell me, what went wrong. Please insert the error-output here, so that we can give you real help.

And I also assume, that there are some dependency-problems or held packages, so that something could have gone wrong with installing of these stated programs.

The easiest way in this case is to try to boot into the recovery-mode (the second line in the Grub-Bootmanager; therefore, keep the shift-key pressed during boot to enter Grub-Bootmenue).

There, these programs should be uninstalled again and then try to reboot. If it works and you get back to your desktop, open the Terminal and run complete update and dist-upgrade by typing in these commands:

sudo apt-get update

Let this run through completely! Then enter this command:

sudo apt-get dist-upgrade

Let this also run through completely. Then close the Terminal and try to reboot. Does this work?? If so and if your are able to get back to your desktop, then open Synaptic and install these photo-editing programs again.

Question: does Synaptic give any error-outputs during install?? Does it say anything about broken or held packages?? If so, then please return back here, so that we can help you.

Greetings Andrea

share|improve this answer
    
Thanks Andrea. I will try to enter the recovery-mode as you suggest. In the meantime, here's a link to a screenshot of my boot screen where it gets stuck. Hope this helps.dropbox.com/s/wipydx3502cv9ty/… –  ThorOdin May 2 at 19:41
    
Andrea,I have managed to get into recovery-mode. I have tried a dpkg:repair broken packages. It did a few thing and seems to want to access the web. So I've enabled networking and re-run dpkg. It has downloaded and updated a few packages (Thunderbird being one of them). I have tried a fsck:check all file systems but there seemed to be read/write access issue. I've also tried grub: update grub bootloader. Again, it did a few things but still unable to boot to my desktop. I've tried failsafex but all I got was a blipping cursor with no way to do anything. Is there anything else I should try ? –  ThorOdin May 2 at 20:10
    
Can anyone help ? It's been a week without a computer. How do I bump this thread ? –  ThorOdin May 7 at 13:12
    
@ignis I think I have managed to remove lightdm and darktable using sudo apt-get remove lighdm. I am now stuck at the four dots. Pressing ESC shows me two fails. one is * Starting load fallback graphics devices the other one is * Starting LightDM Display Manager. Don't know what to try now... –  ThorOdin May 9 at 19:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.