Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My wifi only works occasionally, it seems to be worst when I'm coming off my Windows boot and going straight to Ubuntu. Most every morning, it works perfectly fine. In my Windows installation, I usually have to turn off the wireless adapter before it works, but that trick does not work in Ubuntu. I'm running 12.04 LTS, 32 bit. These are my ifconfig and netstat data:

wlan0     Link encap:Ethernet  HWaddr 48:5d:60:9d:41:13  
      inet addr:192.168.0.100  Bcast:192.168.0.255  Mask:255.255.255.0
      inet6 addr: fe80::4a5d:60ff:fe9d:4113/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:16 errors:0 dropped:0 overruns:0 frame:0
      TX packets:193 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:2804 (2.8 KB)  TX bytes:24647 (24.6 KB)

Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         192.168.0.1     0.0.0.0         UG        0 0          0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 wlan0
192.168.0.0     0.0.0.0         255.255.255.0   U         0 0          0 wlan0
share|improve this question
    
Do you press "restart" or "shutdown" when you want to move to Ubuntu from Windows? –  Deecaf May 1 at 20:56

1 Answer 1

Your output looks quite fine so far.

Question: did you set up your wifi-connection correctyl in network-manager in Ubuntu?? Question: did a notice show up on your screen saying "wireless networks available" after booting into Ubuntu??

If so, then your connection is not set up correctly in your network-manager in Ubuntu.

To set up your wifi-connection-correctly, go to your menue. In your menue, select system-preferences. In the system-preferences, select network-connections.

There enter all your data (including your wifi-key). And do not forget to check these both options on the very first window in network-manager:

"automaticly connect to this network, if present". "allow all users to use this network".

These both options need to be checked.

Then on the top, you need to set up a name for your connection. For example "connection (here replace these brackets with your own name!!)

Then in the second window, select IP4 and enter your wlan-key.

In the third window with IPv6 select "ignore".

Save these changes and close network-manager.

Return back to your panel and click the nm-applet. Then it should see your network. Select your network. Then it should connect automaticly.

Greetings Andrea

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.