Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently upgraded to Xubuntu 14.04 on my laptop. Prior to 14.04, I used xrandr (through a script) to configure my preferred layout, which involved an external VGA monitor and the built in laptop monitor. Prior to 14.04, when I closed the lid with that layout active, the layout remained the same (ie, the built-in monitor was off, but still present in the layout).

After upgrading to 14.04, my xrandr layout is retained only for as long as I don't close the lid on the laptop. After the lid is closed, the external monitor is reconfigured as the only display. After the lid is reopened, Xfce seems to restore whatever configuration I had set for the two monitors in the displays dialog prior to closing the lid. This is suboptimal for me, as I cannot make the monitors bottom-aligned through that dialog, which is why I'd prefer my xrandr layout be respected through lid closes.

A previous question suggests looking into ACPI configuration and removing lid close scripts there, but I seem to have no scripts that do anything with the lid in /etc/acpi. I also haven't been able to find anything to do with lid closes in /etc/udev. Xfce power manager is set to do nothing with lid closes, and that setting seems to be respected – if I set it to suspend, it suspends. The "Configure new displays when connected" checkbox in Xfce display settings is unchecked.

share|improve this question
Perhaps the values for the lid in the "/etc/systemd/logind.conf" can help you. Or is there anything in the "/proc/acpi/" folder ? – TuKsn May 2 '14 at 9:29
logind.conf is set to ignore lid events entirely. I have /proc/acpi/ibm/video (I'm on a Thinkpad), which allows me to turn auto expansion of displays on or off, but regardless of what state I leave that setting in, the same thing happens when I close the lid. Not sure if that's a bug or intended behavior. – D__ May 2 '14 at 14:21
Did you change it with root permissions ? There are any options for the lid behavior in the BIOS-Settings ? – TuKsn May 2 '14 at 14:29
video requires root to cat or write to, so yes. catting video shows the auto option toggled as it was told to, but it has no tangible effect otherwise. BIOS setup has nothing about lids. – D__ May 3 '14 at 1:44
Perhaps this answers will help… If not you can report it as an bug if you want – TuKsn May 3 '14 at 8:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.