Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to set up Conkeror as my default browser. However, in the Preferred Applications menu, this is not an option, nor do I see a method of inputting a custom setting/command.

Does anyone know a way round this?

[Edit: I've tried (1) using sudo update-alternatives --config x-www-browser as well as using gconf-editor to edit /desktop/gnome/url-handlers/http, /desktop/gnome/url-handlers/https, /desktop/gnome/applications/browser/exec. Neither of these seems to work. ]

share|improve this question
add comment

5 Answers 5

sudo update-alternatives --config x-www-browser

Result shoud be:

There are 3 choices for the alternative x-www-browser 
(providing /usr/bin/x-www-browser).

  Selection    Path                       Priority   Status
------------------------------------------------------------
* 0            /usr/bin/xlinks2            69        auto mode
  1            /usr/bin/chromium-browser   40        manual mode
  2            /usr/bin/firefox            40        manual mode
  3            /usr/bin/xlinks2            69        manual mode

Press enter to keep the current choice[*], or type selection number: 

But you will have conkeror too.

Result after choosing 1:

update-alternatives: using /usr/bin/chromium-browser to provide /usr/bin/x-www-browser (x-www-browser) in manual mode.

share|improve this answer
1  
Yes, tried that before, and conkeror was already set as default. It isn't, however, what shows up in the Dash as the preferred browser. And whatever browser shows up in the Dash as the preferred browser is actually what the system seems to end up using as the preferred browser... –  BeSlayed May 29 '11 at 19:27
    
That's not what you asked. Your comment is a bug/regression: bugs.launchpad.net/ubuntu/+bug/775422 and not something AskUbuntu can help with. –  Rinzwind May 29 '11 at 20:00
    
@BeSlayed You should update your question with the different things you've tried, that way people can update their answers with new information. –  Jorge Castro May 30 '11 at 18:38
add comment

On my 10.10, there are a number of gnome configuration key called

/desktop/gnome/url-handlers/http
/desktop/gnome/url-handlers/https
/desktop/gnome/applications/browser/exec

which you can change to a point to a different browser. Use gconf-editor to make the changes. I can't say if the same applies to 11.04. What you could try is to search for "firefox" (or whatever is set as your default browser), again in gconf-editor, and change all the relevant entries.

share|improve this answer
    
Thanks, this definitely allows me to alter the configuration directly. I'm still having trouble getting conkeror in particular to be set as default. I'm not sure why. (I can set it (e.g. conkeror %u) but it just uses another browser instead).) –  BeSlayed May 29 '11 at 21:07
    
I have added a third key and more instructions - perhaps more luck now? –  loevborg May 30 '11 at 8:09
    
Still no luck. I think it has to do in part with the way that Conkeror is set-up. –  BeSlayed May 30 '11 at 18:39
add comment

Since I have the same problem and no one mentioned it, I am going to mention setting:

update-alternatives --install /usr/bin/gnome-www-browser  gnome-www-browser conkeror

That is what is used by /usr/bin/sensible-browser, the default in:

/desktop/gnome/url_handlers/http
/desktop/gnome/url-handlers/https
/desktop/gnome/applications/browser/exec

Conkeror still doesn't show up in the default applications dialog though.

EDIT: Solved it with this .desktop file:

#!/usr/bin/env xdg-open

[Desktop Entry]
Version=1.0
Type=Application
Terminal=false
Icon=conkeror.png
Name=Conkeror
Comment=Emacs like Web Browser
GenericName=Web Browser
Exec=conkeror.sh %u
Categories=GNOME;GTK;Network;WebBrowser;
MimeType=text/html;text/xml;application/xhtml+xml;application/xml;application/vnd.mozilla.xul+xml;application/rss+xml;application/rdf+xml;image/gif;image/jpeg;image/png;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;x-scheme-handler/chrome;video/webm;

From here:

https://bugs.launchpad.net/ubuntu/natty/+source/gnome-control-center/+bug/708382/comments/4

https://bugs.launchpad.net/ubuntu/natty/+source/gnome-control-center/+bug/708382

share|improve this answer
    
Thanks! This was driving me crazy, and I didn't notice the end of the MimeType line at first, starting with the x-scheme-hander stuff: that was the crucial addition in my case. (Ubuntu 12.10, using openbox as the WM.) –  jon Jan 23 '13 at 21:07
add comment

Click the off button very right on the panel. The dropdown menu shows system setting, open it and navigate to personal, preferred application.

share|improve this answer
    
This method takes me to the Preferred Applications menu, just the same as typing in "Preferred Applications" in the Dash does. –  BeSlayed May 29 '11 at 19:39
add comment

Can you set it in Konqueror? In Google Chrome for example, you can pick to have it as the default web-browser, after which the Dash is automatically updated to reflect this.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.