Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a Dell XPS 15 which has 2 display outputs, one HDMI which is apparently driven by the onboard intel graphics card, one DP driven by the nVidia card. I've tried to setup a triple screen setup (onboard monitor, HDMI and DP) and its all working nicely except that the two monitors driven by the Intel card have some horrible visual artifacts permanently flickering on the screen.

They do not appear when taking a screenshot so its got to be something to do with the graphics card/driver. I've gone a bit retro and taken a photo of one of the screens to illustrate it.

enter image description here

I think I got a bit unlucky with the photo, most of the time there are way more dotted lines than that, covering the screen. They flicker around quite a lot. Interestingly while they don't appear on the nVidia-driven screen usually, if I drag a window over there then the artifacts appear around the outside of the edge of the window.

These visual artifacts do not appear when the nVidia card is disabled (so the intel card is not just broken). Its only when using nVidia prime to display on both sets of screens.

Any ideas for what I can try? It feels like I've tried every imaginable setting on nVIdia settings and on Compiz.


share|improve this question
Could you add output of sudo lshw -c display showing both cards? – Sneetsher May 6 '14 at 13:04
how is the exact name of the bios ?! version of bios ?! what is your bios saying about graphics-card-built-in ?! at boot-prompt before first lines of the system before windows 8 or before Linux there is to press key 'F2' or else F-key ... ?! and which processor do you have exactly ?! – dschinn1001 May 12 '14 at 20:10
@Marogian - this could be too, that graphics-chipset is not correctly supported by BIOS ?! or that there is a part of the chipset not correctly working because the driver for the graphics-card is hindered by false reset of BIOS (efi or uefi?!) ?! – dschinn1001 Nov 7 '14 at 8:23
@at start of booting - you can press key 'F2' just to watch what version of BIOS or EFI or UEFI you have ?! - – dschinn1001 Nov 7 '14 at 8:37
@marogian, Hello there! Sorry for asking in an old question. Did you manage to remove this artifacts? if you done with 'em, please left a comment. – Ilya Yarkovets Apr 30 at 9:18

There is a solution of mine with this cuda-SDK-beta-1.1 package of NVIDIA ... but this is not for beginners, and it is risky to test it, but it cannot damage your hardware ... Here I post this link, where my workout, worked on my little laptop a good while - BUT you should first wait for new upcoming answers, if somebody has a better solution. Test this posted contribution at the end of all answers.

How can I Install Nvidia Driver GT 520 and Cuda 5.0 in Ubuntu13.04?

Your Dell-Laptop is only different by BIOS and that it is optimized for Win'8 ... not sure if this solution would work, probably you would have to modify the steps.

Also test this at the end of all answers.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.