Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have quite a big problem. I did this:

  1. I have Win 7 for quite a long time
  2. I have installed Ubuntu 11.04 as dual boot with Win 7
  3. First day (also during installation) wired internet was running.
  4. I have tried to hibernate Ubuntu -> Laptop was turned off 5) I turned on Laptop next day. From dual boot menu I have picked Ubuntu but there was a prob.. just black screen
  5. I have done hard reset
  6. From that point ethernet (wired internet) is not running. In Ubuntu I have following error: SIOCSIFADDR: No such device eth0 eth0: ERROR while getting interface flags: No such device

I have no idea what to do and I cannot understand how can this effect both systems. If you have any also small hints let me know, I'm desperate.. Thx

share|improve this question

From the original author

Ok these guys had the solution. The network adapter was in deep sleep, so I had to unplugged the power cable and took out battery which resets the motherboard - and the network device.

Not really much of a solution, however that seems to have fixed it for the author

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.