Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am currently trying to install Ubuntu 14.04 on a Sony Vaio that came pre-installed with Windows 8 in (I understand) UEFI mode. And I am experiencing the dual-boot hell. I already tried most of the suggestions in the exhaustive Installing Ubuntu on a Pre-Installed Windows 8 (64-bit) System (UEFI Supported) guide as well as Ubuntu installations when using UEFI, but I still experience issues so please do NOT mark the current question as duplicate.

These are the steps that I already did:

  1. Use a 64-bit 14.04
  2. In the BIOS I could NOT find nor disable QuickBoot/FastBoot and Intel Smart Response Technology (SRT). But I did disable FastStartup in Windows 8.
  3. In BIOS I disabled SecureBoot.
  4. I installed 14.04 in UEFI mode (the /etc/fstab contains the UEFI partition) by using manual partitioning on the GPT hard-drive. I reduced the size of the Windows 8 partition from within Windows 8, as recommended.
  5. After the installation I noticed dual-booting issues, so attempted to use boot-repair (following this guide). But it only ended in an error and didn't fix much.

Issue:

Windows 8 always boots fine. When somehow I manage to get to the grub screen then choosing Ubuntu or Windows 8 will result in either OS booting just fine. So dual-booting sort of works. However, most of the times the Vaio will simply boot to Windows 8 after a shutdown or restart.

To get to the grub screen reliably, I am currently using the following awkward workaround:

  • While holding the SHIFT key, I click on Restart within Windows-8: enter image description here
  • When the menu below appears, I select Use a device: enter image description here
  • Then I select Ubuntu: enter image description here

Afterwards the GRUB menu appears and I can boot Ubuntu. For this to work I had to enable External Device Boot in BIOS and set in the Boot priority that the External Device (1) should be before the Internal HDD (2).

Question:

  • How can I fix the dual-boot issues on the laptop? I would like to be able to get straight to the GRUB screen whenever I restart the computer, either from Windows 8 or from Ubuntu.
share|improve this question
    
A related question with hints of Vaio firmware issues: askubuntu.com/questions/360285/13-10-on-vaio-pro-with-uefi –  landroni May 8 at 3:58
    
This is what (finally!) worked for me: ubuntuforums.org/… simple and elegant –  Henk Jun 24 at 8:46
add comment

4 Answers 4

One Sony user posted this:

The trick was to manually copy the ubuntu Boot directory in place of the \EFI\Boot Directory, and rename shimx64.efi to \EFI\Boot\bootx64.efi (not \EFI\Microsoft\Boot\bootmgfw.efi )

Boot-Repairs fix is the rename of bootmgfw.efi, which has to be redone if Windows updates its files. And then can only boot Windows from grub menu.

Some other options:

Alternative to Boot-Repairs rename of shim. Some systems work better to register grub/shim from inside Windows - for those that keep resetting Windows as default

Grub not showing on startup for Windows 8.1 Ubuntu 13.10 Dual boot

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

https://coderwall.com/p/vfyqkg

Some install rEFInd which seems to be another workaround.

http://www.rodsbooks.com/refind/index.html

http://www.rodsbooks.com/refind/secureboot.html

share|improve this answer
add comment

I had the same issue here. To fix, try the steps below:

  1. Disable secure boot, fastboot, etc... (you have already done that);
  2. When installing Ubuntu, choose manual partitioning and create the partitions as follows:
    1. An ext4 partition for system and home (if you want). Mount point: /
    2. A swap partition. I normally use 50% of available RAM;
    3. A ext2 partition for boot. I think 400mb is enough. Mount point: /boot;
  3. Install Ubuntu, but do not restart after the installation finishes.
  4. Install gparted: sudo apt-get install gparted
  5. Open gparted. Select your disk and then the boot (ext2) partition. Right click on /boot partition, select manage flags and enable bios_grub flag. Apply change and close gparted.
  6. Install boot-repair like this link and execute it normally using recommended settings.

If everything is right, boot-repair will find your Windows 8 and will configure grub for you. Now, you can reboot.

Hope it helps.

share|improve this answer
add comment

Try this. I had the same problem with Ubuntu 14.04 and Windows 7 and that worked just fine for me.

share|improve this answer
    
I already tried to fix the issue using Boot-Repair, as mentioned in the question. What exactly do you think I should try from that guide? –  landroni Apr 30 at 16:36
    
Oh, sorry for my bad post then. I don't have any other solution for your problem. Hope you will find one soon. –  Ragnar Apr 30 at 16:38
    
Instead of posting a link-only answer, consider copying (and citing) the essential answer components. That way, if your link goes dead, your answer has value for future users. Also see this Stack Overflow Meta advice on writing good answers. –  Clayton May 1 at 2:02
add comment

If a boot device option does not appear for your device: Check the options in the firmware menus to enable or disable BIOS-compatibility mode.

To use BIOS-compatibility mode, check for options in the firmware menus to disable UEFI SecureBoot features.

For older PCs (Windows® 7-era or earlier), look for options to Boot from file, and browse to the \EFI\BOOT\BOOTX64.EFI file on that device.

stright from MS WEBSITE

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.