Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do I configure usb_modeswitch on Ubuntu 10.04?

When the device is pluged in lsusb gives:

oshirowanen@laptop:~$ lsusb
Bus 001 Device 004: ID 19d2:0103 ONDA Communication S.p.A. 

When I eject the device manually to get it to be recognised as a modem, lsusb gives:

oshirowanen@laptop:~$ lsusb
Bus 001 Device 003: ID 19d2:0031 ONDA Communication S.p.A. ZTE MF636

So then I searched for 19d2 and got:

oshirowanen@laptop:~$ sudo updatedb && locate 19d2
/etc/usb_modeswitch.d/19d2:0053
/etc/usb_modeswitch.d/19d2:2000
/etc/usb_modeswitch.d/19d2:2000:uPr=USB_ZTE
/etc/usb_modeswitch.d/19d2:2000:uPr=ZTE_CDMA
/etc/usb_modeswitch.d/19d2:fff5
/etc/usb_modeswitch.d/19d2:fff6

So it seems there is no usb_modeswitch.conf file in ubuntu 10.04, instead I get these files in /etc/usb_modeswitch.d

Do I need to use one of these 19d2 files, if so, which one and how?

share|improve this question

1 Answer 1

up vote 5 down vote accepted

These are the 2 packages related to usb_modeswitch

usb-modeswitch
usb-modeswitch-data

Please check if both are installed.

/etc/usb-modeswitch.conf is part of usb-modeswitch as you can see here:

im2

I got here by opening synaptic, searching for modeswitch, clicking usb-modeswitch and then clicking properties and installed files.

1 thing: I am using 11.04.
In 10.04 you might have to install your own config file. If you did install from synaptic and it still does not work this topic suggests installing from source: usb-modeswitch and usb-modeswitch-data (but you are on your own here ;) ).

Regarding the edit: see this topic on ubuntuforums

Thanks folks: the advice above worked for me.

I'll summarise what I did here for the benefit of others:

1. I purchased a '3' ZTE MF112 dongle
2. I plugged it in. lsusb gives 19d2:0103
3. `sudo aptitude install usb-modeswitch`
`sudo gedit /etc/udev/rules.d/zte_eject.rules`
SYSFS{idVendor}=="19d2", SYSFS{idProduct}=="0103", RUN+="/usr/bin/eject %k", OPTIONS+="last_rule"
4. reboot
5. lsusb gives 19d2:0031
6. Using NetworkManager > Edit Connections... > Mobile Broadband,
I set up the dongle to access 3's network.

I can now connect whenever I plug in the dongle, provided there 
is good mobile coverage.
share|improve this answer
    
thanks, that was very useful. Please see my updated question above. –  oshirowanen May 29 '11 at 13:45
    
that worked perfectly. Thanks. –  oshirowanen May 29 '11 at 14:15
    
@oshirowanen \o/ \o/ –  Rinzwind May 29 '11 at 14:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.