Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Since Ubuntu 13.04, and now 13.10 and 14.04, my Nautilus (Files) has no application menu.

This means that I can't access Edit>Preferences and can only change preferences via dconf-editor, as the 'show hidden files' option keeps turning itself on.

No, it's not hidden in the global menu, whether the global menu is disabled in settings or not.

I've spent hours searching Google for an answer and tried every suggestion, including:

  • Reinstall Nautilus, removing the ~/.config/nautilus and ~/.config/nautilus-actions folders

  • UBUNTU_MENUPROXY= nautilus

  • Installing the appmenu list of programs

  • Removing the appmenu list of programs

Can anyone help?

share|improve this question
1  
Open Gedit and press Ctrl + O (alphabet o) to open a file. If it shows hidden files, press Ctrl + H to hide them and then close Gedit. Now open Nautilus, does it show the hidden files? And what are you using Ubuntu Unity or Ubuntu GNOME? – Aditya Apr 30 '14 at 12:58
    
Thanks for your time so far, I'm using Unity. The hidden files is not really a big problem, it's just a reason to need to get into preferences. Ctrl H works universally wherever I am. It just doesn't persist between boots and I have to use dconf-editor to disable the setting. Looking in /var/log/kern.log, there are no log entries at all relating to Nautilus or Files whatever I do in Nautilus, only if I mount a drive through Nautilus then a file mount message shows up; nothing else. All other programs are fine, it's just Nautilus. Are there any other config files I could delete? – user276240 Apr 30 '14 at 15:12

I think what you're asking about might be "a feature, not a bug".

Take a look at: http://arstechnica.com/information-technology/2014/02/ubuntu-desktop-moving-application-menus-back-into-application-windows/

It says:

... in May 2012. "By design, the global menu bar displays the menu of the focused window. This proves awkward in some applications with dialogs and multiple windows."

The intent of moving application-specific menus into the global menu bar was to leave more room for content in applications.

Fortunately:

Ubuntu developers wanted to "propose a solution to fix the main UX bug we have [had] in Unity since its very first release: the menus being hard to find or too far from their parent window,"

To find this solution:

Hover over an empty space in the background. Click the menu-button on your mouse (usually the right button). A menu appears; select "Change Desktop Background".

A window will open up, with "All Settings" | "Appearance" and two tabs: "Look" and "Behavior". "Look" will be selected; select "Behavior".

Under "Show the menus for a window", select the "In the window's title bar" option.

That should do it.

share|improve this answer

Run dconf-editor, navigate to org > gtk > settings > file-chooser, then untick show-hidden.

Press Ctrl+h to show hidden files, press it again again to hide them.

share|improve this answer

If you're not root, you can access the preference by clicking on the status bar where it says nautilus. A menu will drop down and you'll be able to access the Preferences from there. This won't work if you're running nautilus as root (as the rest of the shell is not in root).

if you're root, you can access the Nautilus preference via dconf-editor:

alt-f2 (to run) gksudo dconf-editor (it will not lauch from shell under sudo)

you'll find the preference in: org -> gnome -> nautilus -> preferences. They're all there.

share|improve this answer

This issue can be fixed by installing nemo:

First remove nautilus with

sudo apt-get remove --purge nautilus

then download nemo

sudo add-apt-repository ppa:webupd8team/nemo
sudo apt-get update
sudo apt-get install nemo nemo-fileroller

Then your folders might disappear in places like the desktop. They should return after some time. If not, then please restart the PC.

You don't have to delete nautilus, but then you have to keep opening nemo and do all from there. Also, if you search for nemo it will show you a application called Files. Don't get confused by that, it's still nemo.

share|improve this answer

Press the alt key.

OR ...

Move your mouse to the top of the screen.

share|improve this answer

protected by Community Dec 30 '14 at 20:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.