Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded from Ubuntu 13.10 to 14.04. Everything is fine, except the brightness of my laptop screen. When I change the brightness the screen simply does not respond. I figured this was a graphics driver issue, but having updated and reinstalled all nvidia drivers the problem persists. It's rather nasty, as the screen is now permanently set to the darkest setting, making it almost impossible to see anything.

I also tried the solution proposed here: Ubuntu 14.04 - brightness problem in HP hybrid laptop but this, sadly, didn't help either.

I have a HP Elitebook 8560w, with an nvidia Quadro 1000M and am running the latest nvidia-current drivers available in the apt-get repo's

For the record, I tried experimental nvidia drivers, which consequently crashed my entire OS. Therefore, I reinstalled 14.04 cleanly, yet this problem still persists

share|improve this question
    
Same issue with clean 14.04 installation on HP ProBook 470 with AMD HD 8750M 2GB. Screen brightness always set to maximum. I use default Ubuntu drivers as AMDs are not available. –  user2655700 Apr 30 '14 at 11:34
    
I've noticed some new behaviour. When I suspend Ubuntu and wake it up again, the brightness is considerable higher. I still can't adjust it, but it is workable (which is some progress at least) –  danielvdende Jul 15 '14 at 7:17
    
I have this exact computer, and am experiencing this issue too, except my brightness is constantly at maximum. Did you ever find a solution? –  Seth Sep 4 '14 at 2:22
    
@Seth No not yet. Though I think I have the max brightness thing too after I have suspended Ubuntu. Very frustrating for such a simple (yet essential) function to be so broken... –  danielvdende Sep 4 '14 at 7:04
    
I should add that I no longer have this laptop (it died sadly), so I can't try any of the proposed workarounds or solutions. Perhaps @Seth or anyone else could try these and report if they work? I can't accept an answer until I know it works of course :) –  danielvdende 2 days ago

3 Answers 3

up vote 1 down vote accepted
+50

Looks like it's a bug, only with drivers > 304, and that it has been around for a while:

Ubuntu 13.10 kernel version 3.11.0-15.25-generic 3.11.10: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1281019 Suggested workarounds: using nvidia drivers 304

Ubuntu 13.10 kernel version 3.11.0-12.19-generic 3.11.3: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-319/+bug/1241745 Suggested workarounds: using nvidia drivers 304

Ubuntu 14.04 kernel version 3.13.0-24.47-generic 3.13.9: https://bugs.launchpad.net/linuxmint/+bug/1400404 Suggested workarounds: none

Ubuntu 14.04 kernel version 3.13.0-32.57-generic 3.13.11.4: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1349002 Suggested workarounds: none

Ubuntu 12.04 https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/998489 Suggested workarounds: none

Try to roll back to nvidia drivers version 304 (if possible). Sadly if that doesn't fix it or you're unable to roll back to that version, and nobody else comes up with a working hotfix you might have to wait for nvidia to fix the issue in newer version of the drivers

share|improve this answer
    
I'll try this out later although I am pretty sure I've tried it already. Feels like we've been waiting for ages :-( –  Seth Feb 24 at 0:08
    
Wow, I was sure I tried this but it works! Somewhat.. The whole slider only changes the brightness about 3 levels total and both ends make it go completely dark but it's MUCH better than only one setting. Thanks! –  Seth yesterday
    
@Seth I'm glad that it worked, try to play with various version of the 304 to see if some works better than another. Unfortunately from what i've read chances this is going to be fixed soon are low, every bug report i read on this problem was classified as low/medium and/or attributed to a driver (nvidia) regression and almost always expired, but good luck! –  kos yesterday

I got it to work on a Lenovo W510 with a Quadro FX 880M by creating /usr/share/X11/xorg.conf.d/20-nvidia.conf with the following contents:

Section "Device"
    Identifier    "Device0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName     "Quadro FX 880M"
    Option        "RegistryDwords" "EnableBrightnessControl=1"
EndSection

After reboot my brightness controls work correctly.

share|improve this answer
    
Just tried this, sadly to no avail :( –  danielvdende Sep 2 '14 at 8:20

Not a solution but rather a workaround.

There should be a file /sys/class/backlight/acpi_video0/brightness

In this file you have a particular decimal value which corresponds to brightness.

Now, when I use openbox desktop environment, my fn key doesn't work, which is why i use the following script to set it:

#!/bin/mksh
printf " \n Entering file to change brightness in 3 seconds\n remember - no new line after number.  ";
sleep 3;
sudo nano /sys/class/backlight/acpi_video0/brightness

Now, you may want to check the /sys/class/backlight folder just to make sure that you have acpi_video0 file there. It may be named differently for your system

I will link a relevant askubuntu question if you're interested in varioius workarounds for setting brightness

share|improve this answer
    
Nope, I've got the acpi_video0 folder. I tried changing the value in /sys/class/backlight/acpi_video0/brightness but nothing happened. –  Seth 2 days ago

protected by Community Nov 2 '14 at 21:29

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.