Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 2011.04 from scratch a few hours ago. At first Firefox was working perfectly. Then I selected "Static application switcher" in the Compiz configuration.

From that time, whenever I press ALT-TAB, Firefox's display is frozen. As hinted by the changing mouse cursor, I can click on link and select text, but I can not see it.

If I restart Firefox or simply unmaximize/remaximize it, the problem is gone, until the next ALT-TAB.

What's going wrong? How to go back to the deafult (non Compiz?) application switcher?

Note: I am using the proprietary ATI driver Ubuntu proposed me to install.

share|improve this question

closed as off topic by Marco Ceppi Feb 2 '12 at 3:42

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
The problem disappeared after selecting the Compiz "Static application switcher". –  Nicolas Raoul May 29 '11 at 10:46
    
Answer your own question and then select it as the correct answer when you are able to. –  Oxwivi May 29 '11 at 10:59
    
This question should instead be filed as a bug report, thanks! Instructions here. –  Jorge Castro Feb 2 '12 at 1:26

2 Answers 2

This is an answer if you didn't check your settings correctly. Static application switcher is a watered down version of application switcher. It is generally more stable than the latter as well. When I switched from static application switcher to the more powerful application switcher I started observing the problems you mentioned: windows became locked until I resized them. The problem went away as soon as I disabled application switcher (which is a shame because it is so cooler).

Word of caution: re-enabling static application switcher made my system totally unresponsive to the point where I had to hold down the power button. Afterwards, however, everything returned to normal, after reboot

share|improve this answer
up vote 0 down vote accepted

I would have liked to really solve the problem, but meanwhile here is how to avoid the problematic consequence: Select the Compiz "Static application switcher".

share|improve this answer
    
Ya but static application switcher sucks. The system should not crash just because the user wants to use a different option –  puk Nov 4 '11 at 22:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.